This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1262635 - [abrt] spice-vdagent: vdagentd_uinput_destroy(): spice-vdagentd killed by SIGABRT
[abrt] spice-vdagent: vdagentd_uinput_destroy(): spice-vdagentd killed by SIG...
Status: CLOSED DUPLICATE of bug 1268666
Product: Fedora
Classification: Fedora
Component: spice-vdagent (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Victor Toso
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0d1d2ec7c09eabfb022dd02e201...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-13 13:42 EDT by Ashish Bhurtel
Modified: 2015-10-21 14:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 14:59:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.66 KB, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: cgroup (218 bytes, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: core_backtrace (2.97 KB, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: dso_list (1.95 KB, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: environ (72 bytes, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: maps (9.81 KB, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: mountinfo (4.30 KB, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: namespaces (81 bytes, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: open_fds (509 bytes, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: proc_pid_status (1.09 KB, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details
File: var_log_messages (648 bytes, text/plain)
2015-09-13 13:42 EDT, Ashish Bhurtel
no flags Details

  None (edit)
Description Ashish Bhurtel 2015-09-13 13:42:35 EDT
Version-Release number of selected component:
spice-vdagent-0.16.0-1.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/sbin/spice-vdagentd
crash_function: vdagentd_uinput_destroy
executable:     /usr/sbin/spice-vdagentd
global_pid:     757
kernel:         4.3.0-0.rc0.git7.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (4 frames)
 #6 vdagentd_uinput_destroy at src/vdagentd-uinput.c:81
 #7 check_xorg_resolution at src/vdagentd.c:571
 #8 update_active_session_connection at src/vdagentd.c:645
 #9 main_loop at src/vdagentd.c:881
Comment 1 Ashish Bhurtel 2015-09-13 13:42:38 EDT
Created attachment 1072974 [details]
File: backtrace
Comment 2 Ashish Bhurtel 2015-09-13 13:42:39 EDT
Created attachment 1072975 [details]
File: cgroup
Comment 3 Ashish Bhurtel 2015-09-13 13:42:40 EDT
Created attachment 1072976 [details]
File: core_backtrace
Comment 4 Ashish Bhurtel 2015-09-13 13:42:41 EDT
Created attachment 1072977 [details]
File: dso_list
Comment 5 Ashish Bhurtel 2015-09-13 13:42:42 EDT
Created attachment 1072978 [details]
File: environ
Comment 6 Ashish Bhurtel 2015-09-13 13:42:42 EDT
Created attachment 1072979 [details]
File: limits
Comment 7 Ashish Bhurtel 2015-09-13 13:42:43 EDT
Created attachment 1072980 [details]
File: maps
Comment 8 Ashish Bhurtel 2015-09-13 13:42:44 EDT
Created attachment 1072981 [details]
File: mountinfo
Comment 9 Ashish Bhurtel 2015-09-13 13:42:45 EDT
Created attachment 1072982 [details]
File: namespaces
Comment 10 Ashish Bhurtel 2015-09-13 13:42:46 EDT
Created attachment 1072983 [details]
File: open_fds
Comment 11 Ashish Bhurtel 2015-09-13 13:42:47 EDT
Created attachment 1072984 [details]
File: proc_pid_status
Comment 12 Ashish Bhurtel 2015-09-13 13:42:47 EDT
Created attachment 1072985 [details]
File: var_log_messages
Comment 13 Victor Toso 2015-09-14 05:22:03 EDT
This is was introduced by a leak fix
http://cgit.freedesktop.org/spice/linux/vd_agent/commit/?id=4835df0b642dfc963e7cbaabfe93da86482f0b93

Taking a look...
Comment 14 Victor Toso 2015-09-15 02:45:03 EDT
Are you able to always reproduce it?
Can you test with this scratch build?

koji.fedoraproject.org/koji/taskinfo?taskID=11090167
Comment 15 Victor Toso 2015-09-15 04:43:22 EDT
(In reply to Victor Toso from comment #14)
> Are you able to always reproduce it?
> Can you test with this scratch build?
> 
> koji.fedoraproject.org/koji/taskinfo?taskID=11090167

Please, ignore above scratch build. If you can reliable reproduce you can test the following scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=11091414

Patch sent to mailing list:
http://lists.freedesktop.org/archives/spice-devel/2015-September/021905.html
Comment 16 Cole Robinson 2015-10-21 14:59:36 EDT

*** This bug has been marked as a duplicate of bug 1268666 ***

Note You need to log in before you can comment on or make changes to this bug.