Bug 1268666 - [abrt] spice-vdagent: vdagentd_uinput_destroy(): spice-vdagentd killed by SIGABRT
Summary: [abrt] spice-vdagent: vdagentd_uinput_destroy(): spice-vdagentd killed by SIG...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spice-vdagent
Version: 23
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christophe Fergeau
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0d1d2ec7c09eabfb022dd02e201...
: 1262635 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-04 12:55 UTC by Giulio 'juliuxpigface'
Modified: 2015-10-21 18:59 UTC (History)
7 users (show)

Fixed In Version: spice-vdagent-0.16.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-07 16:34:57 UTC


Attachments (Terms of Use)
File: backtrace (5.74 KB, text/plain)
2015-10-04 12:55 UTC, Giulio 'juliuxpigface'
no flags Details
File: cgroup (195 bytes, text/plain)
2015-10-04 12:55 UTC, Giulio 'juliuxpigface'
no flags Details
File: core_backtrace (3.24 KB, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: dso_list (1.82 KB, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: environ (72 bytes, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: maps (5.71 KB, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: mountinfo (3.66 KB, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: namespaces (81 bytes, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: open_fds (506 bytes, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: proc_pid_status (830 bytes, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details
File: var_log_messages (859 bytes, text/plain)
2015-10-04 12:56 UTC, Giulio 'juliuxpigface'
no flags Details

Description Giulio 'juliuxpigface' 2015-10-04 12:55:44 UTC
Description of problem:
Description of the problem:
ABRT caught a crash of spice-vdagentd


How reproducible:
I haven't tried to reproduce it yet


Steps to reproduce:
1. Prepare a qemu-kvm guest with virt-manager. Edit /etc/libvirt/qemu/guest.xml

Enable 'suspend-to-mem' and 'suspend-to-disk':

<pm>
	<suspend-to-mem enabled='yes' />
	<suspend-to-disk enabled='yes' />
</pm>


2. Install the 32bit spin Fedora Xfce (Final TC1 compose).
3. Run the guest and login to a standard Xfce session.
4. Suspend to disk via GUI.
5. Resume the session, then switch VT sending "CTRL+ALT+F2" (via virt-manager)


Actual results:
spice-vdagentd crashes and ABRT catches the issue. I'm not exactly sure when did the crash occur (if after step 4 nor step 5).

Expected results:
spice-vdagentd should not crash.

Version-Release number of selected component:
spice-vdagent-0.16.0-1.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/sbin/spice-vdagentd
crash_function: vdagentd_uinput_destroy
executable:     /usr/sbin/spice-vdagentd
global_pid:     716
kernel:         4.2.1-300.fc23.i686
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (4 frames)
 #7 vdagentd_uinput_destroy at src/vdagentd-uinput.c:83
 #8 check_xorg_resolution at src/vdagentd.c:571
 #9 update_active_session_connection at src/vdagentd.c:645
 #10 main_loop at src/vdagentd.c:881

Potential duplicate: bug 1262635

Comment 1 Giulio 'juliuxpigface' 2015-10-04 12:55:54 UTC
Created attachment 1079763 [details]
File: backtrace

Comment 2 Giulio 'juliuxpigface' 2015-10-04 12:55:58 UTC
Created attachment 1079764 [details]
File: cgroup

Comment 3 Giulio 'juliuxpigface' 2015-10-04 12:56:04 UTC
Created attachment 1079765 [details]
File: core_backtrace

Comment 4 Giulio 'juliuxpigface' 2015-10-04 12:56:07 UTC
Created attachment 1079766 [details]
File: dso_list

Comment 5 Giulio 'juliuxpigface' 2015-10-04 12:56:10 UTC
Created attachment 1079767 [details]
File: environ

Comment 6 Giulio 'juliuxpigface' 2015-10-04 12:56:13 UTC
Created attachment 1079768 [details]
File: limits

Comment 7 Giulio 'juliuxpigface' 2015-10-04 12:56:18 UTC
Created attachment 1079769 [details]
File: maps

Comment 8 Giulio 'juliuxpigface' 2015-10-04 12:56:26 UTC
Created attachment 1079770 [details]
File: mountinfo

Comment 9 Giulio 'juliuxpigface' 2015-10-04 12:56:29 UTC
Created attachment 1079771 [details]
File: namespaces

Comment 10 Giulio 'juliuxpigface' 2015-10-04 12:56:33 UTC
Created attachment 1079772 [details]
File: open_fds

Comment 11 Giulio 'juliuxpigface' 2015-10-04 12:56:36 UTC
Created attachment 1079773 [details]
File: proc_pid_status

Comment 12 Giulio 'juliuxpigface' 2015-10-04 12:56:39 UTC
Created attachment 1079774 [details]
File: var_log_messages

Comment 13 Victor Toso 2015-10-05 05:36:00 UTC
Hello,

Could you please test with scratch-build bellow? It contains the patches from bug 1262635

koji.fedoraproject.org/koji/taskinfo?taskID=11091414

Comment 14 Fedora Update System 2015-10-05 10:06:39 UTC
spice-vdagent-0.16.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-a7f21b1850

Comment 15 Fedora Update System 2015-10-06 04:22:13 UTC
spice-vdagent-0.16.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update spice-vdagent'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a7f21b1850

Comment 16 Fedora Update System 2015-10-07 16:34:53 UTC
spice-vdagent-0.16.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Cole Robinson 2015-10-21 18:59:36 UTC
*** Bug 1262635 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.