This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1262649 - After upgrade to fedora 23 the radeon driver reports error radeon 0000:01:00.0: VCE init error (-110).
After upgrade to fedora 23 the radeon driver reports error radeon 0000:01:00....
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libdrm (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 1295627 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-13 18:55 EDT by Bill
Modified: 2016-07-07 07:48 EDT (History)
27 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-07 07:48:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample xorg configuration for radeon (715 bytes, text/plain)
2016-04-01 06:30 EDT, Saurav
no flags Details
Xorg log for radeon (20.38 KB, text/plain)
2016-04-01 06:33 EDT, Saurav
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 92722 None None None 2015-12-17 12:54 EST

  None (edit)
Description Bill 2015-09-13 18:55:18 EDT
Description of problem:

Error: radeon 0000:01:00.0: VCE init error (-110).


Version-Release number of selected component (if applicable): fedora 23


How reproducible: Occurs on any boot.


Additional info:

My hardware is Dell Latitude E6540

It has dual graphics Intel/Radeon

There is no real problem for me as I only use the Intel graphics but maybe for some folks this will be a serious problem which is why I am reporting it.

uname -a
Linux dell-lt 4.2.0-300.fc23.x86_64 #1 SMP Fri Sep 4 13:27:08 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Video devices reported by lspci:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars XTX [Radeon HD 8790M] (rev ff)
Comment 1 nmreis 2015-09-24 07:31:04 EDT
The same is happening to me on a DELL e6440:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330]

[root@e6440c-laptop nmreis]# cat /sys/kernel/debug/vgaswitcheroo/switch 
0:DIS: :Pwr:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0

if i try to switch to the descrete card, it will also not work and I end up with a black screen with a log on top saying that the switch was refused. After that I have to perform a cold reset.

I've tried the testcase described here: https://fedoraproject.org/wiki/QA:Testcase_vga_switcheroo
Comment 2 nmreis 2015-09-24 20:50:04 EDT
On my case the error is:

Error: radeon 0000:01:00.0: VCE init error (-22).

right at boot startup.
Comment 3 nmreis 2015-09-24 22:11:42 EDT
I'm actually able to lunch stuff on the discrete graphics by using the DRI_PRIME=1 variable.

Here's the output of that.

nmreis@e6440c-laptop ~]$ DRI_PRIME=1 glmark2
=======================================================
    glmark2 2014.03
=======================================================
    OpenGL Information
    GL_VENDOR:     X.Org
    GL_RENDERER:   Gallium 0.4 on AMD HAINAN (DRM 2.43.0, LLVM 3.7.0)
    GL_VERSION:    3.0 Mesa 11.0.0 (git-c4bae57)
=======================================================
Comment 4 ja 2015-09-28 09:52:31 EDT
Error: radeon 0000:01:00.0: VCE init error (-22). <- in kernel logs with each boot after updating from kernel 4.1.6 to 4.2.1 (ArchLinux);

My computer is Dell E6440, like the person above, I have the same configuration. Intel HD 4600 + Radeon 8670M. This gpu is pretty much used only in these DELLs

I've seen https://bugzilla.kernel.org/show_bug.cgi?id=101441 and also this: http://people.freedesktop.org/~agd5f/radeon_ucode/ -> but I cannot find no Mars XT VCE binary. These are the bins I currently have installed: 
/usr/lib/firmware/radeon/BONAIRE_vce.bin
/usr/lib/firmware/radeon/TAHITI_vce.bin
Comment 5 skkd.h4k1n9 2015-10-27 18:46:49 EDT
My Computer is a ThinkPad Edge E420S, with an Intel® Sandybridge Mobile (Intel® Core™ i5-2430M CPU) and another GPU: AMD/ATI Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]

lspci gives me:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]

I also get the radeon error on any boot of Fedora 23 (it was not the case with Fedora up to 22, it is not the case with Ubuntu up to 15.04). The bug was there with all Fedora kernels from 4.1.6 to the most actual one, 4.2.3-300.fc23.x86_64
Comment 6 Nicolas Large 2015-11-09 13:43:21 EST
I'm having the same issue on the Dell E6540 too. It's the exact same hardware config as Bill. From a soft point of view, I'm on F22 with Kernel 4.2.5-201.fc22.x86_64.

I'm not sure whether this will provide new insight but these are things I've noticed on my side:
 - no config file associated with the graphic card in the xorg.conf.d directories
 - radeontool does not find any device
 - I've tried to re-install the xorg-drv packages for intel and ati: No effect
 - I've tried to install the ATI catalyst proprietary drivers with the patch (following the procedure found here: https://bluehatrecord.wordpress.com/2015/09/17/installing-the-proprietary-amd-catalyst-15-9-fglrx-15-201-driver-on-fedora-22-with-linux-kernel-4-1-6/), but it stops saying the card is not supported (though the Radeon HD 8790M is supported by the driver I've downloaded and used)
 - The command 'jurnalctl -e _COMM=gdm-x-session' returns nothing

Anyone has new information about this issue? Any update?
Comment 7 Nicolas Large 2015-11-09 17:43:10 EST
A quick update: I've finally decided to downgrade the kernel and see what happens. Results a downgrade from 4.2.5-201.fc22.x86_64 to 4.0.4-301.fc22.x86_64 (that was the only one I could access with dnf) seems to solve the issue (at least temporarily). I'll work on this kernel for  a little while and see how it goes. In a few days I'll try to upgrade to an intermediate kernel version (4.1.x) from RPMs and see what happens.
Comment 8 Michael Hofer 2015-11-30 13:05:34 EST
I'm having the same issue on a Lenovo Thinkpad E550 running F23 with kernel 4.2.6-301.fc23.x86_64. Are there any news on this issue? Can I provide any logs?

My output of glmark2 is slightly different, I don't know if this provides any insight:

    glmark2 2014.03
=======================================================
    OpenGL Information
    GL_VENDOR:     X.Org
    GL_RENDERER:   Gallium 0.4 on AMD OLAND (DRM 2.43.0, LLVM 3.7.0)
    GL_VERSION:    3.0 Mesa 11.0.6 (git-2555e00)
Comment 9 Steve Traylen 2015-12-14 14:02:52 EST
I alse see black monitor for radeon card between 4.2.5 and 4.2.6.

dmesg | radeon is very similar for both. 4.2.6 outputs:

[    1.107979] [drm] radeon kernel modesetting enabled.
[    2.247561] radeon 0000:03:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[    2.247564] radeon 0000:03:00.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF
[    2.247579] [drm] radeon: 1024M of VRAM memory ready
[    2.247580] [drm] radeon: 1024M of GTT memory ready.
[    2.252668] [drm] radeon: dpm initialized
[    2.253435] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[    2.268035] radeon 0000:03:00.0: WB enabled
[    2.268037] radeon 0000:03:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xffff88003e783c00
[    2.268039] radeon 0000:03:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0xffff88003e783c0c
[    2.280485] radeon 0000:03:00.0: fence driver on ring 5 use gpu addr 0x0000000000072118 and cpu addr 0xffffc90001832118
[    2.280489] radeon 0000:03:00.0: radeon: MSI limited to 32-bit
[    2.280542] radeon 0000:03:00.0: radeon: using MSI.
[    2.280607] [drm] radeon: irq initialized.
[    3.267482] radeon 0000:03:00.0: fb1: radeondrmfb frame buffer device
[    3.268259] [drm] Initialized radeon 2.43.0 20080528 for 0000:03:00.0 on minor 1


the working 4.2.5 kernel has two extra lines:

[    1.169920] fb: switching to radeondrmfb from EFI VGA

[    3.301101] fbcon: radeondrmfb (fb1) is primary device
Comment 10 Luya Tshimbalanga 2015-12-17 12:54:07 EST
Assigning to the right component as xorg-x11-drv-radeonhd is not available on Fedora repository.
Comment 11 Martin Cermak 2015-12-18 20:37:53 EST
Same thing with Lenovo G50-45 having "VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8280 / R3 Series]"

=======
$ dmesg | grep radeon

... stuff deleted ...

[    8.420390] [drm:radeon_acpi_init [radeon]] *ERROR* Cannot find a backlight controller

... stuff deleted ...

[   41.328525] radeon 0000:01:00.0: VCE init error (-22).
$ uname -r
4.2.3-300.fc23.x86_64
$
=======
Comment 12 Andrej Podzimek 2015-12-19 19:15:44 EST
Same on Dell Inspiron 7548/0AM6R0 with Radeon R7 M265. Black screen occurs after systemctl stop sddm, for example (with no chance to switch the backlight back on or to do anything but a reboot).
Comment 13 Christopher Brown 2016-01-15 04:02:28 EST
Since update to 4.3.3-300.fc23.x86_64, the boot message has changed slightly to multiple output of:


[   44.177259] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   44.177534] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   44.177695] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   44.177852] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   44.178010] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   44.178181] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
Comment 14 axel 2016-01-28 09:42:37 EST
I have same issue on DELL E6540

journalctl:
kernel: [drm:radeon_pm_late_init [radeon]] *ERROR* failed to create device file for power profile
kernel: [drm:radeon_pm_late_init [radeon]] *ERROR* failed to create device file for power method

dmesg:
radeon 0000:01:00.0: VCE init error (-110)

uname -r
4.3.3-301.fc23.x86_64

lspci -vvv| grep -i "VGA compatible"
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars XTX [Radeon HD 8790M] (rev ff) (prog-if ff)

DRI_PRIME=1 glmark2
=======================================================
    glmark2 2014.03
=======================================================
    OpenGL Information
    GL_VENDOR:     X.Org
    GL_RENDERER:   Gallium 0.4 on AMD OLAND (DRM 2.43.0, LLVM 3.7.0)
    GL_VERSION:    3.0 Mesa 11.1.0 (git-525f3c2)
Comment 15 Dobmec 2016-02-11 08:59:55 EST
Same behavior with an HP Zbook15u2 using Fedora 23 on a fresh install.

dmesg:
[   24.144381] radeon 0000:04:00.0: VCE init error (-110).

lspci -vvv| grep -i "VGA compatible"
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) (prog-if 00 [VGA controller])
04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265] (rev ff) (prog-if ff)

DRI_PRIME=1 glmark2
=======================================================
    glmark2 2014.03
=======================================================
    OpenGL Information
    GL_VENDOR:     X.Org
    GL_RENDERER:   Gallium 0.4 on AMD OLAND (DRM 2.43.0, LLVM 3.7.0)
    GL_VERSION:    3.0 Mesa 11.1.0 (git-525f3c2)
=======================================================

and this last sequence open a black windows which will eventually crash my system because of overheating.
Comment 16 mohamed abdallah 2016-02-24 14:01:26 EST
same problem on dell inspiron 3753
Comment 17 Dobmec 2016-02-29 03:48:44 EST
The problem is still here with kernel 4.4.2-301
Comment 18 Ludwig Flask 2016-03-03 10:53:09 EST
I have the same problem on an HP EliteBook 850 G2 using Fedora 23 on a fresh install.

dmesg:
[    4.924454] radeon 0000:04:00.0: VCE init error (-110).

kernel 4.3.5-300.fc23.x86_64
Comment 19 vip.zhijian 2016-03-03 12:28:10 EST
I have the same problem on an ASUS F554L using Fedora 23 upgraded from Fedora 22.

Linux version 4.4.3-300.fc23.x86_64 

lspci

04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars LE [Radeon HD 8530M / R5 M240] (rev ff)

dmesg

[    1.251398] [drm] radeon kernel modesetting enabled.
[    1.268018] radeon 0000:04:00.0: enabling device (0000 -> 0003)
[    1.328529] radeon 0000:04:00.0: VRAM: 2048M 0x0000000000000000 - 0x000000007FFFFFFF (2048M used)
[    1.328532] radeon 0000:04:00.0: GTT: 2048M 0x0000000080000000 - 0x00000000FFFFFFFF
[    1.328617] [drm] radeon: 2048M of VRAM memory ready
[    1.328618] [drm] radeon: 2048M of GTT memory ready.
[    1.337328] [drm] radeon: dpm initialized
[    1.345139] radeon 0000:04:00.0: WB enabled
[    1.345141] radeon 0000:04:00.0: fence driver on ring 0 use gpu addr 0x0000000080000c00 and cpu addr 0xffff880220cc0c00
[    1.345143] radeon 0000:04:00.0: fence driver on ring 1 use gpu addr 0x0000000080000c04 and cpu addr 0xffff880220cc0c04
[    1.345144] radeon 0000:04:00.0: fence driver on ring 2 use gpu addr 0x0000000080000c08 and cpu addr 0xffff880220cc0c08
[    1.345145] radeon 0000:04:00.0: fence driver on ring 3 use gpu addr 0x0000000080000c0c and cpu addr 0xffff880220cc0c0c
[    1.345147] radeon 0000:04:00.0: fence driver on ring 4 use gpu addr 0x0000000080000c10 and cpu addr 0xffff880220cc0c10
[    1.346687] radeon 0000:04:00.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc90001835a18
[    1.448294] radeon 0000:04:00.0: VCE init error (-110).
[    1.448310] radeon 0000:04:00.0: radeon: MSI limited to 32-bit
[    1.448396] radeon 0000:04:00.0: radeon: using MSI.
[    1.448429] [drm] radeon: irq initialized.
[    2.522583] radeon 0000:04:00.0: No connectors reported connected with modes
[    3.070807] radeon 0000:04:00.0: fb1: radeondrmfb frame buffer device
[    3.078370] [drm] Initialized radeon 2.43.0 20080528 for 0000:04:00.0 on minor 1
[   50.141321] radeon 0000:04:00.0: WB enabled
[   50.141324] radeon 0000:04:00.0: fence driver on ring 0 use gpu addr 0x0000000080000c00 and cpu addr 0xffff880220cc0c00
[   50.141325] radeon 0000:04:00.0: fence driver on ring 1 use gpu addr 0x0000000080000c04 and cpu addr 0xffff880220cc0c04
[   50.141326] radeon 0000:04:00.0: fence driver on ring 2 use gpu addr 0x0000000080000c08 and cpu addr 0xffff880220cc0c08
[   50.141328] radeon 0000:04:00.0: fence driver on ring 3 use gpu addr 0x0000000080000c0c and cpu addr 0xffff880220cc0c0c
[   50.141329] radeon 0000:04:00.0: fence driver on ring 4 use gpu addr 0x0000000080000c10 and cpu addr 0xffff880220cc0c10
[   50.142882] radeon 0000:04:00.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc90001835a18
[   50.244506] radeon 0000:04:00.0: VCE init error (-110).
Comment 20 Saurav 2016-04-01 06:30 EDT
Created attachment 1142505 [details]
Sample xorg configuration for radeon

Adapted this configuration from the one used by Ubuntu for fglrx. Basically changed the "fglrx" to "radeon".
Comment 21 Saurav 2016-04-01 06:33 EDT
Created attachment 1142507 [details]
Xorg log for radeon

Xorg log when trying to use radeon.
Comment 22 Saurav 2016-04-01 06:48:03 EDT
I have attached a sample Xorg configuration for using the radeon driver, basically the Ubuntu fglrx configuration (fglrx works on Ubuntu 15.10) with "fglrx" replaced by "radeon".

The radeon driver basically seems unable to find a screen to its liking, 
> (EE) RADEON(0): No modes.
> (EE) Screen(s) found, but none have a usable configuration.
and then gives up altogether:-
> (EE) no screens found(EE)

This happens irrespective of whether the module parameter radeon.runpm = 0 or not. Trying to use vga_switcheroo with echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch results in a reversion to the login screen with a message saying that client 0 refused to switch, or in a totally black screen (but the system keeps working and can be powered off normally by pressing the power button), after logging out, depending on the display manager being used (the former typically happens with GDM).
Comment 23 Saurav 2016-04-04 06:43:16 EDT
I have reported my findings in bug #1323645 and upstream at https://bugs.freedesktop.org/show_bug.cgi?id=94811 after receiving a message on the upstream bug tracked by this one that these findings may not be related to this bug.

Bug #1295627 may be related to this one.
Comment 24 Igor Gnatenko 2016-07-07 07:46:41 EDT
*** Bug 1295627 has been marked as a duplicate of this bug. ***
Comment 25 Igor Gnatenko 2016-07-07 07:48:35 EDT
Let's track in upstream.

Note You need to log in before you can comment on or make changes to this bug.