Bug 1262803 - No FIPS hmac file for /lib/sse2/fipscheck/libgmp.so.10
No FIPS hmac file for /lib/sse2/fipscheck/libgmp.so.10
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gmp (Show other bugs)
7.1
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Frantisek Kluknavsky
Filip Holec
: ZStream
Depends On:
Blocks: 717789 1264401
  Show dependency treegraph
 
Reported: 2015-09-14 07:58 EDT by Nikos Mavrogiannopoulos
Modified: 2016-04-18 06:27 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1264401 (view as bug list)
Environment:
Last Closed: 2015-11-20 05:27:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Mavrogiannopoulos 2015-09-14 07:58:20 EDT
Description of problem:
gmp installs a .hmac file for /usr/lib/fipscheck/libgmp.so.10 but not for the library in /lib/sse2/fipscheck/libgmp.so.10. That means that in platforms where the /lib/sse2 library is used we cannot run the FIPS validation routine.

How reproducible:
cat <<_EOF_ >c.c
#include <gnutls/gnutls.h>
int main()
{
gnutls_global_init();
}
_EOF_

Steps to Reproduce:
1. gcc -m32 -lgnutls c.c
2. ./a.out

Actual results:
Error in GnuTLS initialization: Error while performing self checks.


Expected results:
Nothing.
Comment 11 Frantisek Kluknavsky 2015-09-16 10:50:50 EDT
Where is the correct place to store the second hash? Libraries have the same name, only path is different.
Comment 12 Tomas Mraz 2015-09-16 11:17:28 EDT
It should be stored in /usr/lib/sse2/fipscheck/
Comment 20 Jan Kurik 2015-11-20 05:27:00 EST
This bug has been closed as CURRENTRELEASE due to delivery of the fix in a z-stream. As the component is not on ACL, the fix is currently included in y-stream as well.

For more information please see the zstream process documentation:
* https://engineering.redhat.com/trac/ZStream/attachment/wiki/WikiStart/Z-Stream_process_update_4.odp .

Note You need to log in before you can comment on or make changes to this bug.