Bug 1263009 - [RFE] SAML Federated Identity
Summary: [RFE] SAML Federated Identity
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 10.0 (Newton)
Assignee: Adam Young
QA Contact: Rodrigo Duarte
Martin Lopes
URL:
Whiteboard:
: 1189630 1189636 1189645 1189646 1289502 (view as bug list)
Depends On:
Blocks: 1273812 1339058 1369294
TreeView+ depends on / blocked
 
Reported: 2015-09-14 21:49 UTC by Nathan Kinder
Modified: 2019-09-12 08:55 UTC (History)
10 users (show)

Fixed In Version: openstack-keystone-10.0.0-0.20160822052050.0cd732b.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:15:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Nathan Kinder 2015-09-14 21:49:40 UTC
Keystone has had SAML Federation support for some time now.  This functionality needs to be tested.  From an end user perspective, this includes:

- Using SAML to authenticate to Horizon via it's WebSSO functionality
- Using SAML ECP to authenticate to Keystone via the 'openstack' CLI
- Using one RHEL OSP cloud to authenticate to another RHEL OSP cloud (K2K)

Comment 8 Nathan Kinder 2016-03-18 18:39:16 UTC
*** Bug 1189636 has been marked as a duplicate of this bug. ***

Comment 9 Nathan Kinder 2016-03-18 18:40:02 UTC
*** Bug 1189645 has been marked as a duplicate of this bug. ***

Comment 10 Nathan Kinder 2016-03-18 18:40:36 UTC
*** Bug 1189646 has been marked as a duplicate of this bug. ***

Comment 11 Nathan Kinder 2016-03-18 18:42:17 UTC
*** Bug 1189630 has been marked as a duplicate of this bug. ***

Comment 12 Mike McCune 2016-03-28 23:13:32 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 16 Nathan Kinder 2016-09-02 20:13:32 UTC
*** Bug 1289502 has been marked as a duplicate of this bug. ***

Comment 19 errata-xmlrpc 2016-12-14 15:15:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.