Bug 1263062 - Can create a content view and promote it straight from Library to the "production" environment, by-passing all other lifecycle environments
Can create a content view and promote it straight from Library to the "produc...
Status: CLOSED DUPLICATE of bug 1104346
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 00:56 EDT by Nelli Zinder
Modified: 2015-10-16 13:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 13:07:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nelli Zinder 2015-09-15 00:56:58 EDT
Description of problem:

When creating a new Content View, I can publish it in the Library, and then promote to ANY environment (e.g. Production), by-passing Development and any previous environments which form part of the predefined lifecycle. Is this a design feature (is this why there is a star next to the "suggested environment")?

Version-Release number of selected component (if applicable):
6.1

How reproducible:

Always

Steps to Reproduce:
1. Create a Content view (and associate Puppet modules, repositories,etc)
2.Publish the view into the library
3.Assume Current lifecycle is Library-> Development -> ProdProd -> Prod. 
4.Promote into Prod (without promoting into Development and Preprod). An error message comes up "Force Promote? Suggested Environment is Development". 
5.Select "Promote" in the error message - the content is now being promoted straight to Prod 

Same goes for any version of the Content View, which can be promoted to ANY environment, e.g. Pre-Prod (with the same error message).

Actual results:


Expected results:


Additional info:
Comment 1 Bryan Kearney 2015-10-16 13:07:14 EDT

*** This bug has been marked as a duplicate of bug 1104346 ***

Note You need to log in before you can comment on or make changes to this bug.