Bug 1263087 - RHEL7/systemd : can't have server in debug mode anymore
RHEL7/systemd : can't have server in debug mode anymore
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Satish Mohan
glusterd
: ZStream
Depends On:
Blocks: 1271540
  Show dependency treegraph
 
Reported: 2015-09-15 02:23 EDT by Anand Nekkunti
Modified: 2016-06-16 09:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1262627
: 1271540 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:36:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-09-15 02:50:47 EDT
REVIEW: http://review.gluster.org/12175 (systemd/spec/glusterd: Adding EnvironmentFile in glusterd systemctrl serive file.) posted (#1) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 2 Vijay Bellur 2015-09-15 02:52:04 EDT
REVIEW: http://review.gluster.org/12175 (systemd/spec/glusterd: Adding EnvironmentFile in glusterd systemctrl service file.) posted (#2) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 3 Vijay Bellur 2015-09-15 04:35:34 EDT
REVIEW: http://review.gluster.org/12175 (systemd/spec/glusterd: Adding EnvironmentFile in glusterd systemctrl serive file.) posted (#3) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 4 Vijay Bellur 2015-09-15 04:59:12 EDT
REVIEW: http://review.gluster.org/12175 (systemd/spec/glusterd: Adding EnvironmentFile in glusterd systemctrl service file.) posted (#4) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 5 Vijay Bellur 2015-09-15 09:08:41 EDT
COMMIT: http://review.gluster.org/12175 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 63e3806ba3c4d5f196ad2254f63d85b79602705a
Author: anand <anekkunt@redhat.com>
Date:   Tue Sep 15 12:05:51 2015 +0530

    systemd/spec/glusterd: Adding EnvironmentFile in glusterd systemctrl service file.
    
    Issue: glusterd was not running in debug mode, this is because of
    "systemctrl start glusterd" was not reading configuration from glusterd-sysconfig file.
    
    Fix: Set glusterd-sysconfig file as "EnvironmentFile"  and pass args to glusterd.
    
    Change-Id: I6a032a2e86e5a25c39199ddf953bfbd6590d53b6
    BUG: 1263087
    Signed-off-by: anand <anekkunt@redhat.com>
    Reviewed-on: http://review.gluster.org/12175
    Reviewed-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Kaleb KEITHLEY 2015-10-22 13:00:12 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 7 Kaleb KEITHLEY 2015-10-22 13:06:51 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 8 Kaleb KEITHLEY 2015-10-22 13:11:18 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 12 Niels de Vos 2016-06-16 09:36:54 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.