Bug 1271540 - RHEL7/systemd : can't have server in debug mode anymore
RHEL7/systemd : can't have server in debug mode anymore
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anand Nekkunti
glusterd
: ZStream
Depends On: 1263087
Blocks: glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-10-14 04:58 EDT by Anand Nekkunti
Modified: 2016-01-03 23:50 EST (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1263087
Environment:
Last Closed: 2015-11-17 01:00:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-14 05:04:37 EDT
REVIEW: http://review.gluster.org/12358 (systemd/spec/glusterd: Adding EnvironmentFile in glusterd systemctrl service file.) posted (#1) for review on release-3.7 by Anand Nekkunti (anekkunt@redhat.com)
Comment 2 Vijay Bellur 2015-10-15 01:38:10 EDT
COMMIT: http://review.gluster.org/12358 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 8629457bfc0347b0ad459ed0ce69a5f35c1314c7
Author: anand <anekkunt@redhat.com>
Date:   Tue Sep 15 12:05:51 2015 +0530

    systemd/spec/glusterd: Adding EnvironmentFile in glusterd systemctrl service file.
    
    Issue: glusterd was not running in debug mode, this is because of
    "systemctrl start glusterd" was not reading configuration from glusterd-sysconfig file.
    
    Fix: Set glusterd-sysconfig file as "EnvironmentFile"  and pass args to glusterd.
    
    Backport of:
    >Change-Id: I6a032a2e86e5a25c39199ddf953bfbd6590d53b6
    >BUG: 1263087
    >Signed-off-by: anand <anekkunt@redhat.com>
    >Reviewed-on: http://review.gluster.org/12175
    >Reviewed-by: Anoop C S <anoopcs@redhat.com>
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >(cherry picked from commit 63e3806ba3c4d5f196ad2254f63d85b79602705a)
    
    Change-Id: Ib081a2a4bcfbfc1fe4334da1ec8c1dbab0760657
    BUG: 1271540
    Signed-off-by: anand <anekkunt@redhat.com>
    Reviewed-on: http://review.gluster.org/12358
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Raghavendra Talur 2015-11-17 01:00:20 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.