Bug 126318 - system-config-display unable to configure dual monitor
system-config-display unable to configure dual monitor
Status: CLOSED DUPLICATE of bug 136916
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 18:20 EDT by Alessandro Polverini
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
I Attach a working dual head xorg.conf hacked by hand for the benefit or other users facing the same problem (3.86 KB, text/plain)
2004-06-25 12:11 EDT, Alessandro Polverini
no flags Details

  None (edit)
Description Alessandro Polverini 2004-06-18 18:20:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.14

Description of problem:
I'm unable to configure dual monitor using the "Dual Head" feature of
s-c-display.
The "Seconda Video Card" is empty, but I don't have a second video
card, I have a single AGP video card with dual output (one VGA, one
DVI), like most videcards in the market today.

I tried with a Radeon 9600xt and a Geforce 5600xt, and the problem is
the same. Only, with the GeForce, in the "Second Video Card" drop
down, the name of the card appears, but nothing is done.

Configuring dual head by hand on the Radeon works. I had no success
with  the GeForce tough.


Version-Release number of selected component (if applicable):
system-config-display-1.0.14-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC2
2. run s-c-display
3.
    

Actual Results:  No possibility to enable dual head

Expected Results:  Having dual monitor is more and more common (and
*very* useful), it should be supported out of the box

Additional info:

xorg-x11-6.7.0-2
Comment 1 Brent Fox 2004-06-25 11:39:31 EDT
Can you attach the xorg.conf file before and after configuring dual
head?  Unfortunately I don't have either of those cards so it's
difficult to reproduce this problem.  Dual head configuration works ok
for me with my Matrox G450 dual head card.
Comment 2 Alessandro Polverini 2004-06-25 12:08:56 EDT
On my system, with a ATI Radeon 9600 XT, I get the following problems:

- s-c-d says: "Trying with card: VESA driver (generic)" instead of
detecting correctly the card.

- if I try to choose the card "by hand" on the Hardware page of s-c-d,
the 9600SE is not listed

- in the Dual Head page the "Second Video Card" drop down is empty so
I can't enable dual head and press "OK" to confirm

These are the relevant outputs from lspci and lspci -n:

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AQ
[Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AQ [Radeon
9600] (Secondary)

01:00.0 Class 0300: 1002:4151
01:00.1 Class 0380: 1002:4171

I don't have the system with the geforce FX handy, I'll test it in the
next days.

P.S: Radeon is cheap... if I can afford it, I suppose redhat can
afford it :) it's a *very* commond videocard in Italy (on newer pcs)
Comment 3 Alessandro Polverini 2004-06-25 12:11:26 EDT
Created attachment 101417 [details]
I Attach a working dual head xorg.conf hacked by hand for the benefit or other users facing the same problem

This configuration file configure xorg with the following options:
- radeon driver
- two flat panels at 1280x1024 true color
- individual desktops
Comment 4 Jay Truesdale 2004-11-10 20:17:17 EST
I have a dual-head Cirrus Logic GD5480 card that has the same problem
as reported above.

I ran the command from the command line like so:

/usr/bin/system-config-display -v

Here is the output that I received, including an ERROR:

Read configuration file /etc/X11/xorg.conf
Trying with card: Cirrus Logic GD5480
in hydrate_second
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 208,
in ok
    primaryPCIBus = "PCI:%d:%d:%d" % (self.state.get_videocard_PCIBus(),
TypeError: int argument required

Comment 5 Jay Truesdale 2004-11-10 20:19:00 EST
I forgot to mention that this is with FC3.
Comment 6 Paul Nasrat 2004-11-11 16:42:30 EST
Consolidate to single bug - I hope to have a new package for testing
Monday.

*** This bug has been marked as a duplicate of 136916 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:04:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.