Bug 1263193 - [virtio-win][svvp][netkvm]BSoD occurs when boot the win2012R2 guest with "-smp 64"(netkvm driver installed)
Summary: [virtio-win][svvp][netkvm]BSoD occurs when boot the win2012R2 guest with "-sm...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1261243
TreeView+ depends on / blocked
 
Reported: 2015-09-15 09:54 UTC by Yu Wang
Modified: 2015-11-24 08:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:52:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
error_screenshot_DeviceManager (74.66 KB, image/jpeg)
2015-09-15 09:54 UTC, Yu Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Yu Wang 2015-09-15 09:54:48 UTC
Created attachment 1073560 [details]
error_screenshot_DeviceManager

Description of problem:

BSoD occurs when boot the win2012R2 guest with more than 54 cores (netkvm driver installed)

Version-Release number of selected component (if applicable):

qemu-kvm-rhev-2.3.0-22.el7.x86_64
kernel-3.10.0-313.el7.x86_64
virtio-win-prewhql-105/virtio-win-1.7.4-1.el7.noarch
seabios-1.7.5-11.el7.x86_64

How reproducible:

100%

Steps to Reproduce:

1.boot the guest with:
/usr/libexec/qemu-kvm -boot menu=on --nodefaults --nodefconfig -m 256G -smp 64 -cpu Westmere,+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic,hv_time -M pc-i440fx-rhel7.2.0  -uuid f05f8492-4ed5-4dcd-9b85-6f2ffdef0940 -smbios type=1,manufacturer='Red Hat',product='Red Hat Enterprise OpenStack and Red Hat Enterprise Linux with Enterprise Virtualization',version=7Server-0.1,serial='44454C4C-5700-1058-804B-B7 C04 F483258_00:21:9b:58:d2:90',uuid=f0458492-4ed5-4dcd-9b85-6f2ffdef0940 -usb -device usb-tablet,id=tablet0 -drive file=win2k12-R2-Intel-max.raw,if=none,id=drive-virtio0-0-0,format=raw,werror=stop,rerror=stop,cache=none,serial=number -device virtio-blk-pci,drive=drive-virtio0-0-0,id=virti0-0-0,bootindex=1\
 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:e2:52:2a:66:6e,addr=0x04 -uuid 0f9dce8a-2c81-4a48-91b3-9a0bc6b6850c -monitor stdio -vnc :1 -vga cirrus -name win2012R2-INTEL-MAX -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 \
-fda driver-net.vfd -boot menu=on -device usb-ehci,id=ehci0 -drive file=usb-storage-intel-max.raw,if=none,id=drive-usb-2-0,media=disk,format=raw,cache=none,werror=stop,rerror=stop,aio=threads -device usb-storage,bus=ehci0.0,drive=drive-usb-2-0,id=usb-2-0,removable=on -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=b111a,path=/tmp/monitor-win2012R2-intel-max,server,nowait -mon chardev=b111a,mode=readline \

2. Install netkvm driver virtio-win-prewhql-105 when boot to guest


Actual results:

BSOD when the installation completed and can't boot into the guest again

Expected results:

Can boot to the guest succesfully

Additional info:

1 When add multiqueue on boot command, can boot into the guest, but Device Manager(Red Hat VirtIO Ethernet Adapter) shows error "this device cannot start(code 10)"(refer to the attachment)

2 When "-m 256G -smp 54"(or -smp less than 54), can boot to guest succesfully and the Netkvm driver shows normally.

3 When use the netkvm driver from "virtio-win-1.7.4-1.el7.noarch", can boot into the gues normally and netkvm driver shows normally w/ mq

Base on above, it seems a regression bug, and it has blocked our SVVP Test.

Comment 2 Yu Wang 2015-09-15 10:06:55 UTC
Host CPU info for your reference:

CPU Model: Intel(R) Xeon(R) CPU E7- 8860

Memory: 516882 MB

Processor: 80

Comment 11 Yu Wang 2015-09-22 07:35:59 UTC
Reproduced this issue on virtio-win-prewhql-105
Verify this issue on virtio-win-prewhql-110

Steps same as comment#0

Actual Results:
on virtio-win-prewhql-110 (fix version), Can boot to the guest succesfully with mq and "-smp=64"

Base on above, this issue has been fixed already.

Thanks for your greate support.

Comment 12 lijin 2015-09-23 10:10:07 UTC
QE have tested on win2008,win2008R2,win7,win8,win8.1,win2012,win2012R2,win10 guests with "-netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,bus=pci.0,id=net1,mac=00:52:6e:2d:90:b6,mq=on/off,vectors=10,ctrl_vq=on/off -smp 1/2/64",build 110 netkvm driver can be installed correctly and guest network keep alive.

Comment 13 lijin 2015-09-23 10:12:26 UTC
change status to verified according to comment#11 and comment#12

Comment 17 errata-xmlrpc 2015-11-24 08:52:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.