Bug 1263236 - segfault in nautilus_bookmark_set_icon_to_default
segfault in nautilus_bookmark_set_icon_to_default
Status: CLOSED DUPLICATE of bug 1254161
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 08:00 EDT by Martin Simon
Modified: 2015-09-16 11:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 11:34:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2015-09-15 08:00:31 EDT
Description of problem:
Remote connection is probably not quited correctly when it is closed in another tab or multitab instance. I've started nautilus, created new tab, there connected to remote host, switched back to the first tab where I unmounted the remote host and tried to establish the very same connection again from the first tab. Then I got segfault.

I've also found this bug while I was verifying bug 1049966, therefore it can be connected.


Version-Release number of selected component (if applicable):
nautilus-3.14.3-5.el7.x86_64
gvfs-1.22.4-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Open nautilus
2. Create a new tab and switch to it
3. Click Connect to server and connect to remote host, wait until the remote location is fully loaded
4. Switch back to the first tab, still listing the Home directory by default
5. Disconnect by clicking the unmount icon on sidebar
6. From the first tab, try to establish very same remote host connection

Actual results:
Program received signal SIGSEGV, Segmentation fault.
0x0000000000480cb1 in nautilus_bookmark_set_icon_to_default (
    bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:275
275	{
(gdb) bt
#0  0x0000000000480cb1 in nautilus_bookmark_set_icon_to_default (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:275
#1  0x0000000000481018 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:364
#2  0x0000000000481240 in nautilus_bookmark_get_location (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:740
#3  0x0000000000480c8b in nautilus_bookmark_get_uri (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:751
#4  0x0000000000480d60 in nautilus_bookmark_set_icon_to_default (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:283
#5  0x0000000000481018 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:364
#6  0x0000000000481240 in nautilus_bookmark_get_location (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:740
#7  0x0000000000480c8b in nautilus_bookmark_get_uri (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:751
#8  0x0000000000480d60 in nautilus_bookmark_set_icon_to_default (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:283
#9  0x0000000000481018 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0xb58360 [NautilusBookmark]) at nautilus-bookmark.c:364
...

Expected results:
New connection established correctly, no segfault

Additional info:
Once I've got a different backtrace, but I'm not really sure if it is caused by the same error although I suppose it is. Here's the different backtrace:
#0  0x0000000000480cb1 in nautilus_bookmark_set_icon_to_default (bookmark=bookmark@entry=0xb6bb60 [NautilusBookmark]) at nautilus-bookmark.c:275
#1  0x0000000000481018 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0xb6bb60 [NautilusBookmark]) at nautilus-bookmark.c:364
#2  0x0000000000481084 in nautilus_bookmark_constructed (obj=<optimized out>)
    at nautilus-bookmark.c:556
#3  0x00007ffff49e1242 in g_object_new_internal (class=class@entry=0xb82c50, params=params@entry=0x7fffffffda80, n_params=3) at gobject.c:1814
#4  0x00007ffff49e3184 in g_object_new_valist (object_type=object_type@entry=7961376, first_property_name=first_property_name@entry=0x4f77c9 "location", var_args=var_args@entry=0x7fffffffdbd0) at gobject.c:2034
#5  0x00007ffff49e3581 in g_object_new (object_type=7961376, first_property_name=first_property_name@entry=0x4f77c9 "location") at gobject.c:1617
#6  0x0000000000481404 in nautilus_bookmark_new (location=location@entry=0x908da0, custom_name=custom_name@entry=0x0) at nautilus-bookmark.c:763
#7  0x000000000042d770 in load_callback (label=0x0, uri=<optimized out>)
    at nautilus-bookmark-list.c:69
#8  0x000000000042d770 in load_callback (source=<optimized out>, res=<optimized out>, user_data=<optimized out>) at nautilus-bookmark-list.c:467
#9  0x00007ffff4c8ef47 in g_simple_async_result_complete (simple=0x7a0a00 [GSimpleAsyncResult]) at gsimpleasyncresult.c:763
#10 0x00007ffff4c8efc9 in complete_in_idle_cb_for_thread (_data=0x7ac490)
    at gsimpleasyncresult.c:832
---Type <return> to continue, or q <return> to quit---
#11 0x00007ffff46de79a in g_main_context_dispatch (context=0x792200)
    at gmain.c:3109
#12 0x00007ffff46de79a in g_main_context_dispatch (context=context@entry=0x792200) at gmain.c:3708
#13 0x00007ffff46deae8 in g_main_context_iterate (context=context@entry=0x792200, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at gmain.c:3779
#14 0x00007ffff46deb9c in g_main_context_iteration (context=0x792200, 
    context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3840
#15 0x00007ffff4cc1f24 in g_application_run (application=0x76a120 [NautilusApplication], argc=argc@entry=1, argv=argv@entry=0x7fffffffdfd8)
    at gapplication.c:2282
#16 0x000000000042a0fb in main (argc=1, argv=0x7fffffffdfd8)
    at nautilus-main.c:103
Comment 1 Ray Strode [halfline] 2015-09-16 11:34:36 EDT
i chatted with carlos about this and he's confident that this bug and bug 1254161 have the same root cause. He's actively investigating.

Let's dupe the two together for simplicity sake.

*** This bug has been marked as a duplicate of bug 1254161 ***

Note You need to log in before you can comment on or make changes to this bug.