Bug 1263311 - setupNetworks fails with a KeyError exception on 'bridged'
setupNetworks fails with a KeyError exception on 'bridged'
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: SuperVDSM (Show other bugs)
---
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.0-rc3
: 4.17.10
Assigned To: Ido Barkan
Michael Burman
network
: AutomationBlocker
: 1270587 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 10:11 EDT by Simone Tiraboschi
Modified: 2016-02-10 14:15 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:52:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
danken: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47234 None None None Never

  None (edit)
Description Simone Tiraboschi 2015-09-15 10:11:22 EDT
Description of problem:
often setupNetworks fails with a KeyError exception on 'bridged'

In superVdsm logs we can find:
MainProcess|Thread-17::DEBUG::2015-09-15 06:00:09,634::supervdsmServer::109::SuperVdsm.ServerCallback::(wrapper) call setupNetworks with ({'ovirtmgmt': {'nic': 'ens3', 'bootproto': 'dhcp', 'blockingdhcp': True, 'defaultRoute': True}}, {}, {'connectivityCheck': False}) {}
MainProcess|Thread-17::DEBUG::2015-09-15 06:00:09,635::api::872::setupNetworks::(setupNetworks) Setting up network according to configuration: networks:{'ovirtmgmt': {'nic': 'ens3', 'bootproto': 'dhcp', 'blockingdhcp': True, 'defaultRoute': True}}, bondings:{}, options:{'connectivityCheck': False}

...

MainProcess|Thread-17::ERROR::2015-09-15 06:01:12,681::supervdsmServer::113::SuperVdsm.ServerCallback::(wrapper) Error in setupNetworks
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer", line 111, in wrapper
    res = func(*args, **kwargs)
  File "/usr/share/vdsm/supervdsmServer", line 238, in setupNetworks
    return setupNetworks(networks, bondings, **options)
  File "/usr/share/vdsm/network/api.py", line 925, in setupNetworks
    logger, _netinfo)
  File "/usr/share/vdsm/network/api.py", line 760, in _add_missing_networks
    configurator)
  File "/usr/share/vdsm/network/api.py", line 724, in _emergencyNetworkCleanup
    if networkAttrs['bridged']:
KeyError: 'bridged'

Version-Release number of selected component (if applicable):


How reproducible:
often but not always

Steps to Reproduce:
1. deploy ovirt hosted-engine
2.
3.

Actual results:
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer", line 111, in wrapper
    res = func(*args, **kwargs)
  File "/usr/share/vdsm/supervdsmServer", line 238, in setupNetworks
    return setupNetworks(networks, bondings, **options)
  File "/usr/share/vdsm/network/api.py", line 925, in setupNetworks
    logger, _netinfo)
  File "/usr/share/vdsm/network/api.py", line 760, in _add_missing_networks
    configurator)
  File "/usr/share/vdsm/network/api.py", line 724, in _emergencyNetworkCleanup
    if networkAttrs['bridged']:
KeyError: 'bridged'

Expected results:
It always work

Additional info:
Comment 2 Simone Tiraboschi 2015-10-12 08:44:51 EDT
*** Bug 1270587 has been marked as a duplicate of this bug. ***
Comment 3 Michael Burman 2015-11-11 07:16:12 EST
Hi Simone

What exactly failed? the deployment? or the deployment was successful, but some setup networks command failed after it?
Sorry but your steps and descriptions are not clear ...
"
Steps to Reproduce:
1. deploy ovirt hosted-engine"

On what/which point the setup networks command/s failed?

Thanks,
Comment 4 Simone Tiraboschi 2015-11-11 08:28:02 EST
Hosted-engine deployment was failing
Comment 5 Michael Burman 2015-11-15 09:43:52 EST
Verified on - 3.6.0.3-0.1.el6 and:
vdsm-4.17.10.1-0.el7ev.noarch
ovirt-hosted-engine-ha-1.3.2.1-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
Comment 6 Sandro Bonazzola 2015-11-27 02:52:46 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.