Bug 1270587 - [hosted-engine-setup] Deployment fails in setup networks, 'bridged' is configured as 'True' by default by vdsm
[hosted-engine-setup] Deployment fails in setup networks, 'bridged' is config...
Status: CLOSED DUPLICATE of bug 1263311
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.3.0
x86_64 Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.0-rc3
: ---
Assigned To: Simone Tiraboschi
Ilanit Stein
integration
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 09:41 EDT by Elad
Modified: 2015-10-27 22:55 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 08:44:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gklein: ovirt‑3.6.0?
gklein: blocker?
ebenahar: planning_ack?
ebenahar: devel_ack?
ebenahar: testing_ack?


Attachments (Terms of Use)
/var/log/ (511.29 KB, application/x-gzip)
2015-10-11 09:41 EDT, Elad
no flags Details

  None (edit)
Description Elad 2015-10-11 09:41:55 EDT
Created attachment 1081796 [details]
/var/log/

Description of problem:
Tried to deploy hosted-engine over iSCSI and I got a failure to setup the network:

2015-10-11 15:22:10 DEBUG otopi.context context._executeMethod:156 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 146, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/network/bridge.py", line 185, in _misc
    _setupNetworks(conn, networks, {}, {'connectivityCheck': False})
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/network/bridge.py", line 203, in _setupNetworks
    'message: "%s"' % (networks, code, message))
RuntimeError: Failed to setup networks {'ovirtmgmt': {'nic': 'eno1', 'bootproto': 'dhcp', 'blockingdhcp': True, 'defaultRoute': True}}. Error code: "16" message: "Unexpected exception"
2015-10-11 15:22:10 ERROR otopi.context context._executeMethod:165 Failed to execute stage 'Misc configuration': Failed to setup networks {'ovirtmgmt': {'nic': 'eno1', 'bootproto': 'dhcp', 'blockingdhcp': True, 'd
efaultRoute': True}}. Error code: "16" message: "Unexpected exception"

Version-Release number of selected component (if applicable):
vdsm-xmlrpc-4.17.8-1.el7ev.noarch
vdsm-yajsonrpc-4.17.8-1.el7ev.noarch
vdsm-python-4.17.8-1.el7ev.noarch
vdsm-jsonrpc-4.17.8-1.el7ev.noarch
vdsm-4.17.8-1.el7ev.noarch
vdsm-cli-4.17.8-1.el7ev.noarch
vdsm-infra-4.17.8-1.el7ev.noarch
[root@green-vdsc ~]# rpm -qa |grep ovirt
ovirt-vmconsole-host-1.0.0-0.0.6.master.el7ev.noarch
libgovirt-0.3.3-1.el7.x86_64
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
ovirt-setup-lib-1.0.0-1.el7ev.noarch
ovirt-vmconsole-1.0.0-0.0.6.master.el7ev.noarch
ovirt-hosted-engine-ha-1.3.0-1.el7ev.noarch
ovirt-host-deploy-1.4.0-0.0.5.master.el7ev.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted-engine


Actual results:
Deployment fails in setup network:

MainProcess|Thread-17::DEBUG::2015-10-11 15:22:10,753::utils::694::root::(execCmd) FAILED: <err> = 'Running as unit run-4830.scope.\nError: Connection activation failed: No suitable device found for this connectio
n.\n'; <rc> = 4
MainProcess|Thread-17::ERROR::2015-10-11 15:22:10,753::ifcfg::743::root::(start_devices) Failed to ifup device eno1 during rollback.
Traceback (most recent call last):
  File "/usr/share/vdsm/network/configurators/ifcfg.py", line 740, in start_devices
    _exec_ifup(dev)
  File "/usr/share/vdsm/network/configurators/ifcfg.py", line 798, in _exec_ifup
    raise ConfigNetworkError(ERR_FAILED_IFUP, out[-1] if out else '')
ConfigNetworkError: (29, '')
MainProcess|Thread-17::ERROR::2015-10-11 15:22:10,761::supervdsmServer::114::SuperVdsm.ServerCallback::(wrapper) Error in setupNetworks
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer", line 112, in wrapper
    res = func(*args, **kwargs)
  File "/usr/share/vdsm/supervdsmServer", line 237, in setupNetworks
    return setupNetworks(networks, bondings, **options)
  File "/usr/share/vdsm/network/api.py", line 932, in setupNetworks
    logger, _netinfo)
  File "/usr/share/vdsm/network/api.py", line 767, in _add_missing_networks
    configurator)
  File "/usr/share/vdsm/network/api.py", line 731, in _emergencyNetworkCleanup
    if networkAttrs['bridged']:
KeyError: 'bridged'

Expected results:
Deployment should succeed

Additional info:
/var/log/
Comment 1 Yaniv Kaul 2015-10-12 02:12:05 EDT
Does it happen only on iSCSI, or in all scenarios?
Comment 2 Elad 2015-10-12 03:22:46 EDT
(In reply to Yaniv Kaul from comment #1)
> Does it happen only on iSCSI, or in all scenarios?

Happens in all scenarios, I tested over NFS just to make sure.
Comment 3 Simone Tiraboschi 2015-10-12 08:44:51 EDT

*** This bug has been marked as a duplicate of bug 1263311 ***

Note You need to log in before you can comment on or make changes to this bug.