Bug 1263454 - Unable to create project in cloned Git Repo
Unable to create project in cloned Git Repo
Status: VERIFIED
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.1.0
Unspecified Unspecified
high Severity unspecified
: ER4
: 6.2.0
Assigned To: Ryan Zhang
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 15:58 EDT by Khary Mendez
Modified: 2016-04-22 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Khary Mendez 2015-09-15 15:58:17 EDT
Description of problem:
Created a git repo on github containing a single README.md file and cloned it in BPMS 6.1  I then attempted to create a new project within this cloned repo from business central. The "Create new Project" dialog remains on the screen after I click the Ok button and nothing else happens. In the javascript console I see:

"receiver 'org.guvnor.asset.management.service.RepositoryStructureService:RPC.load:org.guvnor.structure.repositories.Repository::26:RespondTo:RPC' threw an exception"

Version-Release number of selected component (if applicable):
Tried in BRMS 6.1.0 and also with the latest patch (6.1.2)

How reproducible:
Always

Steps to Reproduce:
1. Create a repository on GitHub (GitLab had the same behavior)
2. Create a README.md file in the repository
3. Log in to BRMS, select Authoring->Administration->Repositories->Clone Repository
4. Fill in a name, org unit, github url, github username/password, select Clone
5. Acknowledge the confirmation dialog 
6. Authoring -> Project Authoring, select the organization and repo name used above
7. Select New Item -> Project, enter a project name and select Ok

Actual results:
The dialog remains on the screen, the following is logged in the javascript console:

"receiver 'org.guvnor.asset.management.service.RepositoryStructureService:RPC.load:org.guvnor.structure.repositories.Repository::26:RespondTo:RPC' threw an exception"

Expected results:
A new project is created within the cloned repository

Additional info:
Comment 4 Walter Medvedeo 2015-09-25 07:22:40 EDT
the following complementary commits were also added:

kie-wb-distributions
--------------------
master:

https://github.com/droolsjbpm/kie-wb-distributions/commit/17093d13c5c54ecfafef42b7cd36ac5e07cdee2d

6.3.x:

https://github.com/droolsjbpm/kie-wb-distributions/commit/63aa862cba5f4482d2679f66ff2a2dde406fe8e9
Comment 5 Martin Zilak 2015-10-26 08:06:54 EDT
I tried reproducing the steps and everything works as it should.

Note You need to log in before you can comment on or make changes to this bug.