Bug 1263459 - FTBFS in rawhide - remove obsolete dependency qconf, fix segfaults
FTBFS in rawhide - remove obsolete dependency qconf, fix segfaults
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: i7z (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
: FutureFeature
: 1307628 (view as bug list)
Depends On:
Blocks: F24FTBFS 1243639
  Show dependency treegraph
 
Reported: 2015-09-15 16:28 EDT by Raphael Groner
Modified: 2016-03-26 14:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: i7z-0.27.2-13.20131012git5023138.fc23 i7z-0.27.2-13.20131012git5023138.fc24
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 16:51:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2015-09-15 16:28:51 EDT
Description of problem:
i7z is b0rken in rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=11099012

Please explain why BuildRequires: qconf
I fail to find a call to qconf binary.


Version-Release number of selected component (if applicable):
0.27.2-12

How reproducible:
yes

Steps to Reproduce:
1. koji build --scratch rawhide i7z-0.27.2-12.fc22.src.rpm
2.
3.

Actual results:
FTBFS

Expected results:
ok

Additional info:
build.log:
…
Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/i7z-0.27.2-12.fc24.x86_64
RPM build errors:
error: Installed (but unpackaged) file(s) found:
   /usr/share/doc/i7z/MAKEDEV-cpuid-msr
   /usr/share/doc/i7z/README.txt
   /usr/share/doc/i7z/put_cores_offline.sh
   /usr/share/doc/i7z/put_cores_online.sh
    Installed (but unpackaged) file(s) found:
   /usr/share/doc/i7z/MAKEDEV-cpuid-msr
   /usr/share/doc/i7z/README.txt
   /usr/share/doc/i7z/put_cores_offline.sh
   /usr/share/doc/i7z/put_cores_online.sh
Comment 1 Raphael Groner 2015-09-15 16:37:27 EDT
diff --git a/i7z.spec b/i7z.spec
index b14ead0..9257036 100644
--- a/i7z.spec
+++ b/i7z.spec
@@ -1,6 +1,6 @@
 Name:           i7z
 Version:        0.27.2
-Release:        11%{?dist}
+Release:        12%{?dist}
 Summary:        CLI curses based monitoring tool for Intel Core i7 processors
 Summary(fr):    Outil de surveillance en CLI pour processeurs Intel Core i7
 
@@ -10,7 +10,6 @@ Source0:        http://i7z.googlecode.com/files/i7z-%{version}.tar.gz
 
 ExclusiveArch:  %{ix86} x86_64
 
-BuildRequires:  qconf
 BuildRequires:  ncurses-devel
 
 
@@ -42,6 +41,9 @@ make install DESTDIR=%{buildroot} docdir=%{_docdir}/%{name}
 
 
 %changelog
+* Tue Sep 15 2015 Raphael Groner <projects.rg@smart.ms> - 0.27.2-12
+- remove obsolete BR: qconf
+
 * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.27.2-11
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
Comment 2 Raphael Groner 2015-11-15 11:35:09 EST
Ping maintainer, any news here?
Comment 3 Raphael Groner 2016-02-27 12:51:23 EST
This package is heavily b0rken and without fixes since at least mid of September 2015. 

Please orphan it.

https://apps.fedoraproject.org/koschei/package/i7z
Comment 4 Raphael Groner 2016-02-27 13:14:18 EST
*** Bug 1243639 has been marked as a duplicate of this bug. ***
Comment 5 Raphael Groner 2016-02-27 13:16:05 EST
commit 32fa68e1c090595a592ae757b3d8498cd4330667
Author: Uwe Menges <uwe.menges@web.de>
Date:   Thu Jul 16 02:28:40 2015 +0200

    fix segfault on unhandled options

diff --git a/i7z.c b/i7z.c
index e97c5f8..aa71d9b 100644
--- a/i7z.c
+++ b/i7z.c
@@ -490,6 +490,7 @@ int main (int argc, char **argv)
                 break;
 
             case 'h':
+            default:
                 printf("\ni7z Tool Supports the following functions:\n");
  				printf("Display version information only and exit:  ");
                 printf("%c[%d;%d;%dm./i7z --version ", 0x1B,1,31,40);


https://bugzilla.redhat.com/attachment.cgi?id=1052529
Comment 6 Raphael Groner 2016-02-27 13:17:14 EST
*** Bug 1307628 has been marked as a duplicate of this bug. ***
Comment 7 Uwe Menges 2016-02-28 05:29:33 EST
Please note that I requested to include a newer version in https://bugzilla.redhat.com/show_bug.cgi?id=1243639 while this bug seems to aim at build requirement + segfault fix only.

Source0 archive http://i7z.googlecode.com/files/i7z-0.27.2.tar.gz contains README.txt with
Current Version: svn-103 (Sep/2012)
[...]
coder: Abhishek Jaiantilal (abhishek.jaiantilal@colorado.edu)

whereas https://github.com/ajaiantilal/i7z/blob/master/README.txt has
Current Version: git-93 (May/2013)

It is necessary to keep that utility up to date, or it won't know newer CPUs, and possibly showing wrong states.
Comment 8 Raphael Groner 2016-02-28 05:31:04 EST
I'm aware. Latest update policy is essential in Fedora. Just tried to consolidate bugs. Let's wait for the nonresponsive maintainer process.
Comment 9 Raphael Groner 2016-03-01 15:08:28 EST
Nonresponsive maintainer process started.
https://fedorahosted.org/fesco/ticket/1553
Comment 10 Fedora Admin XMLRPC Client 2016-03-07 13:58:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Raphael Groner 2016-03-08 10:07:08 EST
When looking at GitHub forks graph, I'm unsure what fork is to be considered as active development and what to take.
https://github.com/ajaiantilal/i7z/network
Comment 12 Fedora Update System 2016-03-08 12:46:29 EST
i7z-0.27.2-13.20131012git5023138.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0cf4a693dc
Comment 13 Fedora Update System 2016-03-08 12:46:40 EST
i7z-0.27.2-13.20131012git5023138.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fb51f84a82
Comment 14 Fedora Update System 2016-03-09 17:56:14 EST
i7z-0.27.2-13.20131012git5023138.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0cf4a693dc
Comment 15 Fedora Update System 2016-03-09 20:57:05 EST
i7z-0.27.2-13.20131012git5023138.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fb51f84a82
Comment 16 Fedora Update System 2016-03-17 16:51:40 EDT
i7z-0.27.2-13.20131012git5023138.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-03-26 14:18:32 EDT
i7z-0.27.2-13.20131012git5023138.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.