Bug 1263638 - not able to pair sennheiser MM100 headset
not able to pair sennheiser MM100 headset
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bluez (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Don Zickus
Ken Benoit
: Regression
Depends On: 1296616
Blocks: 1313485 1274397
  Show dependency treegraph
 
Reported: 2015-09-16 06:35 EDT by Tomas Pelka
Modified: 2016-11-04 01:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:37:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bluetooth debug log (131.29 KB, text/plain)
2015-09-23 10:28 EDT, Tomas Pelka
no flags Details

  None (edit)
Description Tomas Pelka 2015-09-16 06:35:43 EDT
Description of problem:
Sep 16 12:24:40 dhcp131-186.brq.redhat.com bluetoothd[878]: No agent available for request type 0
Sep 16 12:24:40 dhcp131-186.brq.redhat.com bluetoothd[878]: device_request_pin: Operation not permitted
Sep 16 12:24:40 dhcp131-186.brq.redhat.com bluetoothd[878]: Unable to get connect data for Headset Voice gateway: getpeername: Transport endpoint is not connected (107)

Version-Release number of selected component (if applicable):
bluez-5.23-4.el7
bluez-libs-5.23-4.el7

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
should pair

Additional info:
This is working with bluez-5.29
Comment 2 Don Zickus 2015-09-22 16:20:35 EDT
Hi,

Can you stop the bluetoothd

systemctl stop bluetooth.service


and start by hand with logging?

/usr/sbin/bluetoothd -n -d

and attach the logs?

Updating to bluez-5.29 is not going to work ath this stage. :-(

Cheers,
Don
Comment 3 Tomas Pelka 2015-09-23 10:28 EDT
Created attachment 1076248 [details]
bluetooth debug log

Tied multiple times pairing and connecting the device.

Got also segfault when removing paired device but I can't reproduce.

Device address: 00:07:04:CE:0F:2B
Comment 11 Don Zickus 2016-08-04 17:13:41 EDT
Hi,

The problem seems to be there is no agent registered to handle the PIN transaction.  If you start
a gnome-shell, I believe blueman becomes that agent and can accept the PIN request thus allowing
your headset to pair.

Updating to the latest RHEL-7.3 bluez (bluez-5.39) should resolve the segfaul you are seeing.

Cheers,
Don
Comment 12 Ken Benoit 2016-09-08 13:17:51 EDT
I don't have a pair of these headphones to test with. Tomas, is everything working ok with the latest Bluetooth updates? I've run some Bluetooth testing on my side of things with a Bluetooth speaker, sending files to a cell phone, using a cellphone as a Bluetooth modem, and using a cellphone as a Bluetooth mic and everything seems to be running correctly. Just want to make sure everything is working ok with the headphones so I can mark this as verified.
Comment 13 Vladimir Benes 2016-09-13 03:51:43 EDT
I am able to pair with sennheiser mm100, use A2DP sink and control volume/balance.
Comment 15 errata-xmlrpc 2016-11-04 01:37:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2402.html

Note You need to log in before you can comment on or make changes to this bug.