Bug 1263763 - engine searches for /katello/api/v2 which does not exist with foreman as external provider
engine searches for /katello/api/v2 which does not exist with foreman as exte...
Status: CLOSED DUPLICATE of bug 1260499
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.6.0
Assigned To: Moti Asayag
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 11:53 EDT by Yaniv Bronhaim
Modified: 2016-02-10 14:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 01:32:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Bronhaim 2015-09-16 11:53:16 EDT
Part of gathering errata's info we search for /katello/api/v2 path which does not exist when engine is integrated as external provider with foreman installation. this raises exception each call to GetErrataForSystemQuery which should not be called if katello is not installed 

2015-09-16 18:45:25,796 ERROR [org.ovirt.engine.core.bll.host.provider.foreman.ForemanHostProviderProxy] (default task-43) [] Exception is https://satellite.testenv:8888/katello/api/v2/systems?search=facts.network.hostname:bronhaim.usersys.redhat.com&format=json 
2015-09-16 18:45:25,797 ERROR [org.ovirt.engine.core.bll.GetErrataForSystemQuery] (default task-43) [] Query 'GetErrataForSystemQuery' failed: EngineException: https://satellite.testenv:8888/katello/api/v2/systems?search=facts.network.hostname:bronhaim.usersys.redhat.com&format=json (Failed with error PROVIDER_FAILURE and code 5050)
2015-09-16 18:45:25,797 ERROR [org.ovirt.engine.core.bll.GetErrataForSystemQuery] (default task-43) [] Exception: org.ovirt.engine.core.common.errors.EngineException: EngineException: https://satellite.testenv:8888/katello/api/v2/systems?search=facts.network.hostname:bronhaim.usersys.redhat.com&format=json (Failed with error PROVIDER_FAILURE and code 5050)
	at org.ovirt.engine.core.bll.provider.BaseProviderProxy.getResponse(BaseProviderProxy.java:139) [bll.jar:]
	at org.ovirt.engine.core.bll.provider.BaseProviderProxy.runHttpMethod(BaseProviderProxy.java:185) [bll.jar:]
	at org.ovirt.engine.core.bll.provider.BaseProviderProxy.runHttpMethod(BaseProviderProxy.java:163) [bll.jar:]
	at org.ovirt.engine.core.bll.host.provider.foreman.ForemanHostProviderProxy.runHttpGetMethod(ForemanHostProviderProxy.java:65) [bll.jar:]




Steps to Reproduce:
1. we should not call GetErrataForSystemQuery when foreman is the provider
Comment 1 Moti Asayag 2015-09-17 01:32:14 EDT

*** This bug has been marked as a duplicate of bug 1260499 ***
Comment 2 Yaniv Bronhaim 2015-09-17 05:19:06 EDT
Not sure how much I agree with the duplication. Fixing Bug #1260499 will fix both - but imo we should have some differences between foreman integration to full satellite installation. The API path can be different with foreman and might be less robust than with satellite with katello. Engine should treat it differently

Note You need to log in before you can comment on or make changes to this bug.