This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1260499 - System Errata query is invoked repeatedly and unnecessarily
System Errata query is invoked repeatedly and unnecessarily
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Alexander Wels
movciari
:
: 1263763 1275375 1284595 1284910 1286390 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 02:17 EDT by Moti Asayag
Modified: 2016-03-11 02:19 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 02:19:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
ylavi: planning_ack?
oourfali: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47057 master MERGED webadmin: Prevent auto-refresh engine's errata Never
oVirt gerrit 47099 ovirt-engine-3.6 MERGED webadmin: Prevent auto-refresh engine's errata Never

  None (edit)
Description Moti Asayag 2015-09-07 02:17:41 EDT
Description of problem:
The system errata query is invoked repeatedly by the webadmin. When the engine server is registered to Katello/Satellite server, it lead to great slowness of the system.

Invoking the System Errata query should be limited only to a selection of 'Errata' on the system-tree.

Version-Release number of selected component (if applicable):
commit 6b86f301d5eaba7ffa10b829bbcdc8d1acac3740

How reproducible:
always

Steps to Reproduce:
1. Start the engine
2. Open webadmin
3. Check the engine.log for messages with "org.ovirt.engine.core.bll.host.provider.foreman.ForemanHostProviderProxy"

Actual results:
There are a lot of calls to engine's system errata query

Expected results:
Invoking the system query should be limited to selecting the 'Errata' on the system-tree.

Additional info:
Comment 1 Moti Asayag 2015-09-17 01:32:14 EDT
*** Bug 1263763 has been marked as a duplicate of this bug. ***
Comment 2 Moti Asayag 2015-10-26 13:47:05 EDT
*** Bug 1275375 has been marked as a duplicate of this bug. ***
Comment 3 Yaniv Lavi (Dary) 2015-10-29 08:32:39 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 4 Oved Ourfali 2015-11-24 01:38:13 EST
*** Bug 1284595 has been marked as a duplicate of this bug. ***
Comment 5 Sandro Bonazzola 2015-11-24 12:15:43 EST
Target milestone and target release are not coherent. Please align them either to 3.6.1 or to 3.6.0.
Comment 6 Moti Asayag 2015-11-25 00:17:40 EST
*** Bug 1284910 has been marked as a duplicate of this bug. ***
Comment 7 Moti Asayag 2015-12-07 04:08:50 EST
*** Bug 1286390 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.