Bug 1263785 - Remove constants duplication in ovirt-engine-dwh and ovirt-engine-setup
Summary: Remove constants duplication in ovirt-engine-dwh and ovirt-engine-setup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-dwh
Classification: oVirt
Component: Setup
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Ido Rosenzwig
QA Contact: Gonza
URL:
Whiteboard:
: 1363824 (view as bug list)
Depends On:
Blocks: 1475130 1631198
TreeView+ depends on / blocked
 
Reported: 2015-09-16 17:03 UTC by Rafael Martins
Modified: 2019-04-28 09:53 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:44:26 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
rule-engine: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 62917 master NEW setup: plugins: add constant duplication check 2016-10-06 13:51:36 UTC
oVirt gerrit 64489 master MERGED spec: move engine/constants.py to engine-common package 2016-10-10 07:39:42 UTC
oVirt gerrit 64916 master NEW packaging: setup: Remove constants duplication 2016-10-09 07:06:00 UTC
oVirt gerrit 65129 master MERGED packaging: setup: Remove constants duplication 2016-10-10 08:34:13 UTC
oVirt gerrit 65180 None None None 2016-10-06 15:15:17 UTC
oVirt gerrit 65409 master MERGED packaging: setup: fix constants deduplication for dev-env 2016-10-13 06:43:59 UTC
oVirt gerrit 65567 master NEW spec: correctly move engine/constants.py to engine-common package 2016-10-28 10:21:49 UTC
oVirt gerrit 73339 master ABANDONED packaging: setup: Remove dwh_shared_constants 2017-03-20 07:36:31 UTC
oVirt gerrit 73841 master MERGED packaging: setup: Move dwh-plugins from engine to dwh 2017-03-20 07:35:56 UTC
oVirt gerrit 73842 master MERGED packaging: setup: Move dwh-plugins from engine to dwh 2017-03-20 13:51:53 UTC
Red Hat Bugzilla 1332892 None None None Never
Red Hat Bugzilla 1465859 None None None Never

Internal Links: 1332892 1465859

Description Rafael Martins 2015-09-16 17:03:35 UTC
ovirt-engine-dwh and ovirt-engine-setup have some constants duplicated on its codebases. Need to find a way to centralize these constants.

Suggestion from didi: create a new ovirt-engine-dwh-setup-common or similar, with all the duplicated stuff.

Comment 1 Pavel Stehlik 2015-10-15 11:51:39 UTC
Proposing CodeChange, thus QE just sanity.

Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 11:00:09 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 3 Yedidyah Bar David 2015-12-27 13:50:01 UTC
Simone, IIRC you were for keeping these duplicated. What do you think?

Comment 4 Simone Tiraboschi 2016-03-22 14:52:11 UTC
If everything depends on engine_common or if we have no side effects requiring it everywhere we can just move there.

Comment 6 Sandro Bonazzola 2016-12-02 09:01:26 UTC
Update on this bug status?

Comment 7 Ido Rosenzwig 2016-12-07 06:33:37 UTC
All patches have been merged.

For some reason the status of several patches still 'NEW' but should be 'MERGED'

Comment 8 Ido Rosenzwig 2016-12-08 13:43:12 UTC
The projects that changed are:
 - ovirt-engine
 - ovirt-dwh
 - ovirt-imageio

For testing, please check if all the products are installed correctly and nothing is broken.

Comment 9 Ido Rosenzwig 2016-12-29 10:08:13 UTC
*** Bug 1363824 has been marked as a duplicate of this bug. ***

Comment 10 Lukas Svaty 2017-01-31 11:44:41 UTC
verified in rhevm-4.1.0.2-0.1.el7.noarch

Comment 11 Yedidyah Bar David 2017-02-08 16:06:53 UTC
Reopening. I wasn't aware of [1], which reverts much of the changes for this bug.

We are still affected by it in real life. E.g. patchset 28 of [2] failed, and to prevent the failure I pushed patchset 30, and also [3] for a "proper fix". The intent of current bug was that patches such as [3] would not be needed.

Simone pushed [1] to fix dev-env without dwh. I understand the reasoning and can accept it as a temporary solution, but imo we need a better one on the long term - e.g. make dwh setup mandatory in dev-env, or somehow patch the engine to not fail if it's missing (no idea how much work this will require, the change between 28 and 30 in [2] wasn't hard).

[1] https://gerrit.ovirt.org/65409
[2] https://gerrit.ovirt.org/70422
[3] https://gerrit.ovirt.org/71889

Comment 12 Red Hat Bugzilla Rules Engine 2017-02-08 16:07:08 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 13 Sandro Bonazzola 2017-02-10 08:00:47 UTC
Didi, can you fix this?

Comment 14 Yedidyah Bar David 2017-06-28 12:29:25 UTC
Now got a report that makes me think current bug is still not solved, bug 1465859.

It seems like one of the patches removed [1] websocket-proxy's copy of ENGINE_FQDN, and that the engine's copy [2] wasn't changed to have its attributes.

(The fact that they were different at the time is actually current bug).

[1] https://gerrit.ovirt.org/#/c/65129/9/packaging/setup/ovirt_engine_setup/websocket_proxy/constants.py
[2] https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=blob;f=packaging/setup/ovirt_engine_setup/engine/constants.py;h=bdaee6092954995e86b523c2a8bbf2eee62ec6ff;hb=221c7edba2e615fdd8a7076d5f736d8bde4a6155#l682

Comment 15 Sandro Bonazzola 2017-06-28 12:39:54 UTC
Ido should be back in 1 week, Ido please have a look.

Comment 16 Ido Rosenzwig 2017-07-16 12:20:45 UTC
Working on it.

Comment 17 Sandro Bonazzola 2017-07-19 06:57:15 UTC
Movinf back to assigned as per comment #16

Comment 18 Ido Rosenzwig 2017-07-19 07:34:35 UTC
The additional issue that is mentioned on comment 14 is being tracked on [1].

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1465859

moving back to 'ON_QA'

Comment 19 Gonza 2017-09-11 10:35:03 UTC
Verified with:
ovirt-engine-4.2.0-0.0.master.20170907100709.git14accac.el7.centos.noarch
ovirt-engine-setup-4.2.0-0.0.master.20170907100709.git14accac.el7.centos.noarch
ovirt-engine-dwh-setup-4.2.1-0.0.master.20170906061716.el7.centos.noarch
ovirt-imageio-common-1.1.0-1.el7.noarch

Comment 20 Sandro Bonazzola 2017-12-20 10:44:26 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.