Bug 1465859 - OVESETUP_ENGINE_CONFIG/fqdn value not getting logged in answerfile when installing remote dwh
OVESETUP_ENGINE_CONFIG/fqdn value not getting logged in answerfile when insta...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Setup.EngineCommon (Show other bugs)
4.1.4
Unspecified Linux
unspecified Severity unspecified (vote)
: ovirt-4.1.5
: 4.1.5.2
Assigned To: Ido Rosenzwig
Lukas Svaty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 07:42 EDT by tasdikrahman
Modified: 2017-08-23 04:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-23 04:03:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79455 master MERGED packaging: setup: Add Engine FQDN to the answerfile 2017-07-31 09:17 EDT
oVirt gerrit 80001 ovirt-engine-4.1 MERGED packaging: setup: Add Engine FQDN to the answerfile 2017-08-07 05:19 EDT

  None (edit)
Description tasdikrahman 2017-06-28 07:42:00 EDT
Description of problem:

When I am trying to configure a new remote DWH with a new installation of ovirt-engine,
the answerfile doesn't record the variable which would be used to resolve the engine installation, which is the value of `OVESETUP_ENGINE_CONFIG/fqdn`

Is this an expected behavior?

Version-Release number of selected component (if applicable):
4.1

How reproducible:


Steps to Reproduce:
1. configure your centos7 host to install ovirt-engine and specify the option of not installing and specify No when asked with the prompt `Configure Data Warehouse on this host (Yes, No) [Yes]: `
2. go to a new host where you want your remote dwh to be setup and start the engine-setup for the package `ovirt-engine-dwh-setup`
3. After configuration is done, check the answerfile generated for the variable `OVESETUP_ENGINE_CONFIG/fqdn` which wouldn't be present

Actual results:
OVESETUP_ENGINE_CONFIG/fqdn is not there

Expected results:
OVESETUP_ENGINE_CONFIG/fqdn should be recorded for automation purposes

Additional info:
Comment 1 Yedidyah Bar David 2017-06-28 08:34:06 EDT
Seems like a regression caused by bug 1263785.

How did you notice?

Generally speaking, the answer file should not be touched. The correct way to phrase current bug is: "In some past version, I did X, and it didn't ask me anything, and with 4.1 when I do X it asks me again the fqdn of the engine".

Is it so? If so, what is "X"?

Anyway, thanks for the report!
Comment 2 Yedidyah Bar David 2017-06-28 08:36:29 EDT
I think that X is:

1. Set up an engine on machine A
2. Set up dwh on machine B, engine-setup creates an answerfile Banswers
3. Clean up machine B (or reinstall or whatever), and run engine-setup on it with --config-append=Banswers

Didn't try.
Comment 3 tasdikrahman 2017-06-29 11:02:05 EDT
(In reply to Yedidyah Bar David from comment #1)
> Seems like a regression caused by bug 1263785.
> 
> How did you notice?

I was trying to automate configuring a remote DWH to a fresh engine install using the answerfile (editing it accordingly) and running `engine-setup --config-append=Ans1`  which gave rise to this problem. 

The problem being that the OTOPI variable (OVESETUP_ENGINE_CONFIG/fqdn) was missing out from the answerfile and I had to pry it out from the engine-setup logs.

> 
> Generally speaking, the answer file should not be touched. The correct way
> to phrase current bug is: "In some past version, I did X, and it didn't ask
> me anything, and with 4.1 when I do X it asks me again the fqdn of the
> engine".
> 

What I am trying to say is, in the anwerfile the variable `OVESETUP_ENGINE_CONFIG/fqdn` is not logged. Apart from the other input taken from the user through STDIN. I was asking whether it's an expected behaviour of not logging just that particular input or is it some regression that you mentioned?


> Is it so? If so, what is "X"?
> 
> Anyway, thanks for the report!

Thanks for your time :)
Comment 4 tasdikrahman 2017-06-29 11:03:14 EDT
(In reply to Yedidyah Bar David from comment #2)
> I think that X is:
> 
> 1. Set up an engine on machine A
> 2. Set up dwh on machine B, engine-setup creates an answerfile Banswers
> 3. Clean up machine B (or reinstall or whatever), and run engine-setup on it
> with --config-append=Banswers
> 
> Didn't try.

Exactly! But that should work out by default right? Or am I missing something?
Comment 5 Yedidyah Bar David 2017-07-02 01:37:54 EDT
(In reply to tasdikrahman from comment #4)
> 
> Exactly! But that should work out by default right? Or am I missing
> something?

No, you are completely right. Thanks again for the report!

Leaving current bug open for now, as it is about a specific flow. Ido will have a look at it as part of bug 1263785 and then decide what to do.
Comment 6 Lukas Svaty 2017-08-15 06:29:03 EDT
verified in 

ovirt-engine-setup-plugin-ovirt-engine-common-4.1.5.2-0.1.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.