Bug 1263786 - [abrt] yumex-dnf: status.py:132:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'
[abrt] yumex-dnf: status.py:132:handle_dbus_signals:AttributeError: 'NoneType...
Status: CLOSED DUPLICATE of bug 1224524
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:84eb06cbb76ec24a4544dab9a16...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 13:09 EDT by wincc
Modified: 2015-10-06 04:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 04:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (875 bytes, text/plain)
2015-09-16 13:09 EDT, wincc
no flags Details
File: environ (1.40 KB, text/plain)
2015-09-16 13:09 EDT, wincc
no flags Details

  None (edit)
Description wincc 2015-09-16 13:09:04 EDT
Description of problem:
I started Yum Extender (DNF) nothing happend for 10 seconds I tried to exit then this error happend.

Version-Release number of selected component:
yumex-dnf-4.1.3-2.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.3.0-0.rc1.git0.1.fc24.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
status.py:132:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 71, in __call__
    return getattr(self.proxy, self.method)(*args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 120, in _on_g_signal
    self.handle_dbus_signals(proxy, sender, signal, args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 132, in handle_dbus_signals
    self.app.win.on_status_icon_clicked(force=True)
AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Local variables in innermost frame:
proxy: <DBusProxy object at 0x7f7698109630 (GDBusProxy at 0x563563307200)>
sender: ':1.150'
signal: 'ShowSignal'
run_pid: 3295
args: (3295,)
self: <yumex.status.StatusIcon object at 0x7f769810e048>

Potential duplicate: bug 1233007
Comment 1 wincc 2015-09-16 13:09:08 EDT
Created attachment 1074136 [details]
File: backtrace
Comment 2 wincc 2015-09-16 13:09:09 EDT
Created attachment 1074137 [details]
File: environ
Comment 3 Tim Lauridsen 2015-10-06 04:34:36 EDT

*** This bug has been marked as a duplicate of bug 1224524 ***

Note You need to log in before you can comment on or make changes to this bug.