Bug 1263858 - Make Bugzilla automatically show image attachments
Summary: Make Bugzilla automatically show image attachments
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface   
(Show other bugs)
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: 5.0
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords:
: 1274975 (view as bug list)
Depends On:
Blocks: UI-Modernization
TreeView+ depends on / blocked
 
Reported: 2015-09-16 21:57 UTC by Alexander Todorov
Modified: 2019-03-28 09:45 UTC (History)
7 users (show)

Fixed In Version: 5.0.3-rh31
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 03:08:02 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Todorov 2015-09-16 21:57:19 UTC
Description of problem:

Subject says it all. Looks like it has been rejected in the past (bug #508282) but can't we make an exception for images ?

Comment 1 Jeff Fearn 🐞 2015-09-16 22:45:58 UTC
Do you mean "show image attachments in the browser when you click the link"?

Comment 2 Alexander Todorov 2015-09-18 07:11:12 UTC
Sorry for not being clear. 

I mean show images embedded in the web page. If this is not acceptable though I will satisfy with show images in browser when you click the link (e.g. fix the headers).

Comment 3 Muhammad Tahir 2015-10-26 00:22:34 UTC
*** Bug 1274975 has been marked as a duplicate of this bug. ***

Comment 4 Prarit Bhargava 2015-10-27 12:05:19 UTC
atodorov ... I wonder if this would help?  I haven't had a chance to try it though...

https://github.com/pyrzak/Bugzilla-Extension--Inline-Images

P.

Comment 6 Jeff Fearn 🐞 2017-07-04 10:56:47 UTC
Marking this for Bugzilal 5, which will do the click to load approach, however the cname has disappeared so I've contacted service desk to get it fixed.

Comment 7 Jeff Fearn 🐞 2017-07-11 06:53:45 UTC
This is working onclick now as can be seen by visiting https://beta-bugzilla.redhat.com/show_bug.cgi?id=1263858 and clicking on the PNG attachment.

Comment 8 Richard W.M. Jones 2017-07-11 08:07:30 UTC
Works for me.

Comment 9 Pino Toscano 2019-03-28 09:24:15 UTC
(In reply to Jeff Fearn 🐞 from comment #7)
> This is working onclick now as can be seen by visiting
> https://beta-bugzilla.redhat.com/show_bug.cgi?id=1263858 and clicking on the
> PNG attachment.

This still does not work for me.  In particular, both the following situations fail, e.g. using bug 1658038 as example:
1) if I click on any of the three image attachments, the browser (Firefox 66 on Fedora 29) prompts for an external program to view the image
2) if I click on "Details" of any image attachment, there is no inline content shown, only the text:
   "The attachment is not viewable in your browser due to security restrictions enabled by your Red Hat Bugzilla administrator."

I understand that (2) seems to be bug 508282, however (1) seemed to be fixed by this bug, and it is not.

(BTW, this bug has no PNG attachments...)

Comment 10 Jeff Fearn 🐞 2019-03-28 09:45:26 UTC
(In reply to Pino Toscano from comment #9)
> (In reply to Jeff Fearn 🐞 from comment #7)
> > This is working onclick now as can be seen by visiting
> > https://beta-bugzilla.redhat.com/show_bug.cgi?id=1263858 and clicking on the
> > PNG attachment.
> 
> This still does not work for me.  In particular, both the following
> situations fail, e.g. using bug 1658038 as example:
> 1) if I click on any of the three image attachments, the browser (Firefox 66
> on Fedora 29) prompts for an external program to view the image
> 2) if I click on "Details" of any image attachment, there is no inline
> content shown, only the text:
>    "The attachment is not viewable in your browser due to security
> restrictions enabled by your Red Hat Bugzilla administrator."
> 
> I understand that (2) seems to be bug 508282, however (1) seemed to be fixed
> by this bug, and it is not.
> 
> (BTW, this bug has no PNG attachments...)

When we refresh environments and anything done there gets blown away. Try https://bugzilla.redhat.com/show_bug.cgi?id=1658655#c13 for a currently active discussion.


Note You need to log in before you can comment on or make changes to this bug.