Bug 126392 - need to run gnome-im-settings-daemon manually before gimlet being activated
need to run gnome-im-settings-daemon manually before gimlet being activated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
: 128479 (view as bug list)
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-06-21 01:35 EDT by Lawrence Lim
Modified: 2014-03-25 20:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 23:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of GIMLET in the ja locale. Take note of GIMLET when hangul is actually activated. (154.45 KB, image/png)
2004-06-21 01:37 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2004-06-21 01:35:18 EDT
Description of problem:
In this version of im-sdk, GIMLEt is only visible in the ja locale.
Even when it is visible, it is not working properly as it will always
display "English" and the status window (the yellow box under the
application) remain to be active

Version-Release number of selected component (if applicable):
1) FC 2 (stable)
2)iiimf-server-11.4-60

How reproducible:
Always

Steps to Reproduce:
1. log in at gdm with any CJK locale
2. Add GIMLET to the panel
3. start gedit
  
Actual results:
Unless user is in ja locale, GIMLET will not show.

Expected results:
GIMLET should be displayed in the panel and it should remove status
window from the application.

Additional info:
Comment 1 Lawrence Lim 2004-06-21 01:37:31 EDT
Created attachment 101284 [details]
Screenshot of GIMLET in the ja locale. Take note of GIMLET when hangul is actually activated.
Comment 3 Yu Shao 2004-06-21 02:03:34 EDT
There is one utility added into iiimgcf, gnome-im-settings-daemon,
although "daemon" is very confusing, but if you want GIMLET to display
the status on Panel, you have to configure in it.
Comment 4 Lawrence Lim 2004-06-21 02:47:25 EDT
Thanks for pointing it out, I see what you mean. :)
I would like to point out that there is actually a GUI interface of
gnome-im-settings-daemon called gnome-im-properties. Having said that,
is it possible to have GIMLET as before, without runing the command
gnome-im-settings-daemon?


Thanks,
Lawrence
Comment 6 Leon Ho 2004-07-05 02:14:42 EDT
Now in the latest rawhide, the gimlet can be shown when added. However
whenever the status changes, the gimlet's status text cannot be update
(always 'english') and it also shows the status window under the
application.
Comment 7 Jens Petersen 2004-08-10 04:40:08 EDT
*** Bug 128479 has been marked as a duplicate of this bug. ***
Comment 8 Lawrence Lim 2004-08-26 23:23:09 EDT
Problem fixed with these packages installed:
1) xinitrc-4.0.3-1
2) im-sdk-12.0.1-1.svn1891

Note You need to log in before you can comment on or make changes to this bug.