Bug 1263988 - livecd-iso-to-disk and liveusb-creator (copy mode) images not bootable (due to syslinux / GCC 5 issue)
livecd-iso-to-disk and liveusb-creator (copy mode) images not bootable (due t...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-09-17 05:20 EDT by Lukas Brabec
Modified: 2016-02-13 23:46 EST (History)
15 users (show)

See Also:
Fixed In Version: syslinux-6.03-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 17:08:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Brabec 2015-09-17 05:20:45 EDT
Description of problem:
USB flash drive created with command:
# livecd-iso-to-disk --format --reset-mbr Fedora-Server-DVD-x86_64-23_Beta.iso /dev/sdb

doesn't boot, it is stuck right after USB selection in boot menu, even grub isn't showed.


USB drive created it with command:
# dd if=Fedora-Server-DVD-x86_64-23_Beta.iso of=/dev/sdb

does boot as expected.


Version-Release number of selected component (if applicable):
iso is Fedora 23 Beta RC1
livecd-tools-23.1-2.fc23.x86_64.rpm


Steps to Reproduce:
1. install livecd-tools (f23)
2. run command # livecd-iso-to-disk --format --reset-mbr Fedora-Server-DVD-x86_64-23_Beta.iso /dev/sdb
3. try to use the USB flash drive

Actual results:
flash drive doesn't boot

Expected results:
flash drive boots
Comment 1 Lukas Brabec 2015-09-17 05:23:37 EDT
This also happens when Fedora-Live-Workstation-x86_64-23_Beta-1.iso is used.
Comment 2 Fedora Blocker Bugs Application 2015-09-17 06:04:00 EDT
Proposed as a Blocker for 23-beta by Fedora user lbrabec using the blocker tracking app because:

 Proposing this as blocker bug due to violation of beta criterion:
Initialization requirements: Release-blocking images must boot
Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods.
Comment 3 Adam Williamson 2015-09-17 06:08:00 EDT
The most significant case for writing USB sticks is the current stable releases. Can you check if the current l-i-t-d in F21 and F22 are affected? Thanks!
Comment 4 Kamil Páral 2015-09-17 06:48:38 EDT
I can confirm it works when created from F22.
Comment 5 Adam Williamson 2015-09-17 13:02:24 EDT
Discussed at 2015-09-17 Fedora 23 Beta Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/teams/f23_beta_go_no-go_meeting/f23_beta_go_no-go_meeting.2015-09-17-16.00.log.txt . Rejected as a blocker: it's fairly well-established that we consider the current stable releases to be where this really has to work, not the release under test itself (because usually people are going to be writing F-N+1 media from F-N or F-N-1, not from F-N+1).

So as this works in F22, it's not considered a significant violation of the criteria. We will document it.
Comment 6 Brian Lane 2015-09-17 15:03:48 EDT
It hangs at the SYSLINUX version banner. Looks similar to bug 1234653 but the patch for that is present.
Comment 7 Kamil Páral 2015-09-29 06:49:41 EDT
(In reply to awilliam@redhat.com from comment #5)
> So as this works in F22, it's not considered a significant violation of the
> criteria. We will document it.

That sounds reasonable for Beta, but sounds a bit questionable for Final (our Final product should be able to create a bootable media of itself). Reproposing for Final.
Comment 8 satellitgo 2015-10-05 17:45:39 EDT
# livecd-iso-to-disk --format --reset-mbr --efi Fedora-Live-SoaS-x86_64-23_Beta-1.iso /dev/sdc

boots if EFI in YogaPro2
stops at syslinux 6.03 EDD with or without --efi flag in bios boot of i7 laptop

Tested in 2 different USB's
Comment 9 satellitgo 2015-10-05 17:48:00 EDT
(In reply to satellitgo from comment #8)
> # livecd-iso-to-disk --format --reset-mbr --efi
> Fedora-Live-SoaS-x86_64-23_Beta-1.iso /dev/sdc
> 
> boots if EFI in YogaPro2
> stops at syslinux 6.03 EDD with or without --efi flag in bios boot of i7
> laptop
> 
> Tested in 2 different USB's

note: USB's written in EFI boot of f23 Cinnamon desktop fully updated
Comment 10 Adam Williamson 2015-10-05 18:43:51 EDT
Discussed at 2015-10-05 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-05/f23-blocker-review.2015-10-05-16.00.html . We were kinda uncertain on these; on the one hand it's reasonable in a way to expect the final product to be able to write a USB image of itself, on the other hand we have like four different more-or-less 'supported' USB methods so we don't need yet another OS layer on the test chart that much. The criterion as written does not specify exactly what OSes USB writing must 'work' on, in the past we have considered it a much bigger deal if it fails on the previous releases than on the new one.

We're punting for now to investigate if several related issues are all being caused by the same underlying syslinux bug.
Comment 11 Adam Williamson 2015-10-05 22:25:16 EDT
Current git syslinux doesn't appear to help with this; I built a syslinux with all patches between 6.03 and current git master (as per https://bugzilla.redhat.com/show_bug.cgi?id=1234653#c14 it's easier doing that than actually building right out of git...) and the bug persists.

However, it's definitely caused by syslinux: downgrading to the last F22 build, syslinux-6.03-2.fc22 , makes it work.

So it's very likely down to the hardening changes that came with F23 builds.
Comment 12 Adam Williamson 2015-10-05 22:29:41 EDT
actually perhaps not the hardening stuff, I forgot that I'd done this rodeo before, and none of the hardening changes actually seem to do anything much to the syslinux build - compile and link flags look much the same.

So just as with #1234653, the other obvious candidate is GCC 4.9 vs. 5.1.
Comment 13 Tim Flink 2015-10-12 12:55:05 EDT
Discussed at the 2015-10-12 blocker review meeting [1]:

There is no new information, will attempt to resume discussion at the next blocker review meeting.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-12/f23-blocker-review.2015-10-12-16.01.html
Comment 14 satellitgo 2015-10-15 10:37:10 EDT
# livecd-iso-to-disk --format --reset-mbr Fedora-Live-Workstation-i686-23-TC9.iso /dev/sdb

failed  boots to "syslinux 6.03 EDD" and stops
Comment 15 Adam Williamson 2015-10-15 16:42:58 EDT
Note: there's a couple of patches on the upstream ML which look a lot like they might be fixes for this:

http://www.syslinux.org/archives/2015-September/024318.html
http://www.syslinux.org/archives/2015-September/024319.html

I will test those out this afternoon.
Comment 16 Adam Williamson 2015-10-15 17:11:15 EDT
Discussed at 2015-10-15 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-15/f23-blocker-review.2015-10-15-20.11.log.txt . We agreed to delay the decision one more time (till Monday) while we test the patches on litd and luc.
Comment 17 Adam Williamson 2015-10-15 19:20:47 EDT
Good news: patches seem to work, for me. Can others please confirm? Try writing a stick after updating syslinux from this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=11466483

(the noarch packages are in the i686 build, if you're on x86_64, grab the needed noarch packages from i686).
Comment 18 Kamil Páral 2015-10-16 07:45:04 EDT
(In reply to awilliam@redhat.com from comment #17)
> Good news: patches seem to work, for me. Can others please confirm? Try
> writing a stick after updating syslinux from this scratch build:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=11466483

Yes, it works now.
Comment 19 poma 2015-10-16 11:08:54 EDT
https://github.com/Celelibi/syslinux/tree/fix/bios/gcc5
git clone -b fix/bios/gcc5 https://github.com/Celelibi/syslinux.git

Built w/ GCC5.2.1 on Rawhide
https://bugzilla.redhat.com/show_bug.cgi?id=1243117#c4
http://www.syslinux.org/archives/2015-October/024453.html

You who have successfully tested, send a confirmation to syslinux@zytor.com so upstream devs know it works for you too, to speed up merge w/ http://repo.or.cz/syslinux.git

The credit goes to Sylvain Gault <sylvain.gault@gmail.com>
Comment 20 Fedora Update System 2015-10-16 16:25:19 EDT
syslinux-6.03-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-90d432401e
Comment 21 Fedora Update System 2015-10-17 14:21:25 EDT
syslinux-6.03-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update syslinux'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-90d432401e
Comment 22 satellitgo 2015-10-18 09:48:55 EDT
USB boots f23 workstation tc-11 i686 in (cp) mode on intel atom 280 EeePC netbook
Comment 23 satellitgo 2015-10-18 09:50:57 EDT
(In reply to satellitgo from comment #22)
> USB boots f23 workstation tc-11 i686 in (cp) mode on intel atom 280 EeePC
> netbook

error this is liveusb-creator
Comment 24 Kamil Páral 2015-10-19 10:04:41 EDT
Seems fixed.
Comment 25 Adam Williamson 2015-10-19 12:45:25 EDT
*** Bug 1264012 has been marked as a duplicate of this bug. ***
Comment 26 Adam Williamson 2015-10-19 16:01:45 EDT
Discussed at 2015-10-19 blocker review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-19/f23-blocker-review.2015-10-19-16.00.html . We decided in the end that this doesn't need to block the compose, but we will grant it a freeze exception on the basis that it's probably a good idea to have a not-completely-broken syslinux in the frozen package set. If it causes problems it can be backed out and issued as an update.
Comment 27 Fedora Update System 2015-10-19 17:08:03 EDT
syslinux-6.03-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 28 poma 2016-02-13 23:46:52 EST
See Also:
https://bugzilla.redhat.com/show_bug.cgi?id=1308298

Note You need to log in before you can comment on or make changes to this bug.