Bug 1264012 - liveusb-creator doesn't create bootable Live i686 image in default cp mode
Summary: liveusb-creator doesn't create bootable Live i686 image in default cp mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liveusb-creator
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Depends On:
Blocks: F23FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-09-17 10:17 UTC by Kamil Páral
Modified: 2016-09-20 02:47 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-19 16:45:25 UTC
Type: Bug


Attachments (Terms of Use)
liveusb-creator output (4.05 KB, text/plain)
2015-09-17 10:17 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2015-09-17 10:17:07 UTC
Description of problem:
I've used liveusb-creator to covert F23 Beta RC1 Workstation Live i686 image onto a flash disk. Because liveusb-creator is unbelievably picky, I've erased the beginning of the flash drive with zeroes. Then created MBR. Then created FAT partition. Gave this to liveusb-creator. The resulting flash drive doesn't boot, it displays the SYSLINUX header and then says "Operating system load error". That's all, it's stuck. I tried twice, the same behavior.

I've tried to the same with x86_64 UEFI and that worked. juliuxpigface tried x86_64 BIOS and it worked as well. Seems to be a problem just with i686.

I could have used 'dd' mode in liveusb-creator, and that would have very probably worked. But 'cp' mode is the default, unfortunately.

Version-Release number of selected component (if applicable):
liveusb-creator-3.14.2-2.fc23.noarch
Fedora-Live-Workstation-i686-23_Beta-1.iso

How reproducible:
always for me

Steps to Reproduce:
1. completely erase the drive, create mbr and fat
2. use sudo liveusb-creator -v --reset-mbr
3. the stick doesn't boot

Comment 1 Kamil Páral 2015-09-17 10:17:55 UTC
Created attachment 1074386 [details]
liveusb-creator output

Comment 2 Kamil Páral 2015-09-17 10:20:28 UTC
Proposing as a blocker:
"Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."
https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Release-blocking_images_must_boot

Comment 3 Kamil Páral 2015-09-17 10:33:04 UTC
If you create the image on F22, it works. But there are other minor issues (if you don't have the partition mounted, it crashes) - will be reported shortly.

Comment 4 Kamil Páral 2015-09-17 10:39:09 UTC
(In reply to Kamil Páral from comment #3)
> But there are other minor issues
> (if you don't have the partition mounted, it crashes) - will be reported
> shortly.

So apparently that was caused by unmounting the partition after starting liveusb-creator, and not refreshing the disks in it. It's dumb, but it's not such a problem.

Comment 5 Adam Williamson 2015-09-17 17:04:00 UTC
Discussed at 2015-09-17 Fedora 23 Beta Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/teams/f23_beta_go_no-go_meeting/f23_beta_go_no-go_meeting.2015-09-17-16.00.log.txt . Rejected as a blocker: it's fairly well-established that we consider the current stable releases to be where this really has to work, not the release under test itself (because usually people are going to be writing F-N+1 media from F-N or F-N-1, not from F-N+1).

So as this works in F22, it's not considered a significant violation of the criteria. We will document it.

dgilmore suggests this may be due to the known issues with syslinux in F23, which fits in with the fact that it works on F22 despite luc being the same version in both.

Comment 6 Kamil Páral 2015-09-29 10:51:18 UTC
(In reply to awilliam@redhat.com from comment #5)
> it's fairly well-established that we consider the current stable releases to
> be where this really has to work, not the release under test itself (because
> usually people are going to be writing F-N+1 media from F-N or F-N-1, not
> from F-N+1).

That sounds reasonable for Beta, but sounds a bit questionable for Final (our Final product should be able to create a bootable media of itself). Reproposing for Final.

Comment 7 Adam Williamson 2015-10-05 22:43:36 UTC
Discussed at 2015-10-05 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-05/f23-blocker-review.2015-10-05-16.00.html . We were kinda uncertain on these; on the one hand it's reasonable in a way to expect the final product to be able to write a USB image of itself, on the other hand we have like four different more-or-less 'supported' USB methods so we don't need yet another OS layer on the test chart that much. The criterion as written does not specify exactly what OSes USB writing must 'work' on, in the past we have considered it a much bigger deal if it fails on the previous releases than on the new one.

We're punting for now to investigate if several related issues are all being caused by the same underlying syslinux bug.

Comment 8 Tim Flink 2015-10-12 16:48:37 UTC
Discussed at the 2015-10-12 blocker review meeting [1]:

There is no new information, will attempt to resume discussion at the next blocker review meeting.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-12/f23-blocker-review.2015-10-12-16.01.html

Comment 9 satellitgo 2015-10-15 19:59:49 UTC
I installed the new USB-creator in f23 Cinnamon (EFI) boot

https://copr.fedoraproject.org/coprs/mbriza/liveusb-creator/
selected: mate  x86_64 :

Results:
Note this is the same error as seen in f23 liveusb-creator

liveusb-creator doesn't create bootable Live i686 image in default cp mode
https://bugzilla.redhat.com/show_bug.cgi?id=1264012

"syslinux 6.03 EDD"  boot fails in i7 laptop; bios boot

Comment 10 Adam Williamson 2015-10-15 21:11:31 UTC
Discussed at 2015-10-15 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-15/f23-blocker-review.2015-10-15-20.11.log.txt . We agreed to delay the decision one more time (till Monday) while we test the patches (see #1263988) on litd and luc.

Comment 11 Adam Williamson 2015-10-15 23:21:22 UTC
Good news: patches seem to work, for me with livecd-iso-to-disk. Can folks please test with liveusb-creator and see if this helps? Try writing a stick after updating syslinux from this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=11466483

(the noarch packages are in the i686 build, if you're on x86_64, grab the needed noarch packages from i686).

Comment 12 Kamil Páral 2015-10-16 11:56:20 UTC
(In reply to awilliam@redhat.com from comment #11)
> Good news: patches seem to work, for me with livecd-iso-to-disk. Can folks
> please test with liveusb-creator and see if this helps? Try writing a stick
> after updating syslinux from this scratch build:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=11466483

Works for me.

Comment 13 Fedora Update System 2015-10-16 20:25:27 UTC
syslinux-6.03-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-90d432401e

Comment 14 Fedora Update System 2015-10-17 18:21:29 UTC
syslinux-6.03-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update syslinux'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-90d432401e

Comment 15 Kamil Páral 2015-10-19 14:03:58 UTC
Seems fixed.

Comment 16 Adam Williamson 2015-10-19 16:45:25 UTC

*** This bug has been marked as a duplicate of bug 1263988 ***

Comment 17 Fedora Update System 2015-10-19 21:08:06 UTC
syslinux-6.03-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.