Bug 1264065 - Hosted Engine status show as "Can't connect to HA daemon" after upgrade RHEV-H 7.2 via TUI
Hosted Engine status show as "Can't connect to HA daemon" after upgrade RHEV-...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine (Show other bugs)
3.5.6
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Ryan Barry
cshao
: TestBlocker, TestOnly, ZStream
Depends On: 1270203 1276125 1280310
Blocks: 1264358 1278067
  Show dependency treegraph
 
Reported: 2015-09-17 08:22 EDT by cshao
Modified: 2016-03-09 09:38 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1278067 (view as bug list)
Environment:
Last Closed: 2016-03-09 09:38:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0917.tar.gz (7.98 MB, application/x-gzip)
2015-09-17 08:22 EDT, cshao
no flags Details
engine-error.tar.gz (984.72 KB, application/x-gzip)
2015-09-17 08:28 EDT, cshao
no flags Details

  None (edit)
Description cshao 2015-09-17 08:22:42 EDT
Created attachment 1074418 [details]
0917.tar.gz

Description of problem:
Hosted Engine status show as "Can't connect to HA daemon, please check the logs" after upgrade RHEV-H 7.2 via TUI

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20150913.0
ovirt-node-3.2.3-20.el7.noarch
ovirt-node-plugin-hosted-engine-0.2.0-18.0.el7ev.noarch
ovirt-hosted-engine-setup-1.2.5.3-1.el7ev.noarch
ovirt-host-deploy-1.3.2-1.el7ev.noarch
ovirt-hosted-engine-ha-1.2.6-3.el7ev.noarch
rhevm-appliance-20150831.0-1.x86_64.rhevm.ova
RHEV-M vt 16.9 (3.5.4-1.3.el6ev)

How reproducible:
90%

Steps to Reproduce:
1. Auto install RHEV-H 7.2-20150913.0 (BOOTIF=eth0 storage_init=ata adminpw=xxxxxx firstboot).
2. File the OVA URL with correct path
3. Click <Setup Hosted Engine>
4. Finish the configuration in console. 
5. Reboot RHEV-H.
6. TUI upgrade to rhev-hypervisor-7-7.2-20150913.0
7. Login RHEV-H, check engine status.
8. Check network status in TUI.
9. Check network status in console.

Actual results:
1. Hosted Engine status show as "Can't connect to HA daemon, please check the logs" after upgrade RHEV-H 7.2 via TUI
2. network show as unconfigured.


Expected results:
1. Engine can work fine without error.
2. network is configured and work fine.

Additional info:
Comment 1 cshao 2015-09-17 08:28:46 EDT
Created attachment 1074432 [details]
engine-error.tar.gz
Comment 13 Fabian Deutsch 2015-10-23 03:34:49 EDT
This seems to be completely resolved by bug 1270203
Comment 14 cshao 2015-11-03 02:49:00 EST
Test version:
rhev-hypervisor-7-7.2-20151029.0
ovirt-node-3.2.3-26.el7.noarch
ovirt-node-plugin-hosted-engine-0.2.0-18.0.el7ev.noarch
ovirt-hosted-engine-setup-1.2.6.1-1.el7ev.noarch
ovirt-host-deploy-1.3.2-1.el7ev.noarch
ovirt-hosted-engine-ha-1.2.8-1.el7ev.noarch
rhevm-appliance-20151029.0-1.x86_64.rhevm.ova
Red Hat Enterprise Virtualization Manager Version: 3.5.6.1-0.1.el6ev


Test steps:
1. Auto install RHEV-H 7.2-20151029.0 (BOOTIF=eth0 storage_init=ata adminpw=xxxxxx firstboot).
2. File the OVA URL with correct path
3. Click <Setup Hosted Engine>
4. Finish the configuration in console. 
5. Reboot RHEV-H.
6. TUI upgrade to rhev-hypervisor-7-7.2-20151029.0
7. Login RHEV-H, check engine status.
8. Check network status in TUI.
9. Check network status in console.

Actual results:
1. Engine can work fine without error.
2. network is configured and work fine.

So the bug is fixed with above build, I will verify this bug after bug status change to ON_QA.

Thanks!
Comment 16 cshao 2015-11-12 03:25:34 EST
The bug is blocked by bug 1280310, I will verify this bug after 1280310 fixed.
Comment 17 cshao 2016-01-13 05:16:30 EST
Test version:
RHEV-H 7.2-201501029 + ovirt-node-3.2.3-26.el7.noarch
rhev-hypervisor7-7.2-20160107.0 + ovirt-node-3.6.1-2.0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-6.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.2-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.3.6-1.el7ev.noarch
ovirt-node-plugin-vdsm-0.6.1-4.el7ev.noarch
RHEV-M appliance 20160106.1-1.3.5.ova  

Test steps:
1. Auto install RHEV-H 7.2-201501029 (BOOTIF=eth0 storage_init=ata adminpw=xxxxxx firstboot).
2. File the OVA URL with correct path
3. Click <Setup Hosted Engine>
4. Finish the configuration in console. 
5. Reboot RHEV-H.
6. TUI upgrade to rhev-hypervisor7-7.2-20160107.0
7. Login RHEV-H, check engine status.
8. Check network status in TUI.
9. Check network status in console.

Test results:
1. Engine can work fine without error.
2. network is configured and work fine.

So the bug is fixed, change bug status to VERIFIED.
Comment 19 errata-xmlrpc 2016-03-09 09:38:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.