Bug 1264067 - (CVE-2015-7337) CVE-2015-7337 ipython: Maliciously crafted files can be executed due to wrong file type determination
CVE-2015-7337 ipython: Maliciously crafted files can be executed due to wrong...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20150916,repor...
: Security
Depends On: 1264068
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 08:29 EDT by Adam Mariš
Modified: 2015-10-21 10:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Mariš 2015-09-17 08:29:40 EDT
A vulnerability in IPython allowing maliciously forged file to be opened for editing that could execute javascript code, specifically by being redirected to /files/ due to the mistakenly treating the file as plain text. Versions >= 3.0 and <= 3.2.1 of IPython are affected.

Upstream patch:

https://github.com/ipython/ipython/commit/0a8096adf165e2465550bd5893d7e352544e5967

CVE request:

http://seclists.org/oss-sec/2015/q3/558
Comment 1 Adam Mariš 2015-09-17 08:30:10 EDT
Created ipython tracking bugs for this issue:

Affects: epel-7 [bug 1264068]
Comment 2 Fedora Update System 2015-09-25 03:57:17 EDT
ipython-3.2.1-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.