Bug 1264100 - client to guest - volume synchronization
client to guest - volume synchronization
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-protocol (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Victor Toso
SPICE QE bug list
:
Depends On:
Blocks: 1264102 1264105 1264107 1305834
  Show dependency treegraph
 
Reported: 2015-09-17 10:00 EDT by Victor Toso
Modified: 2016-11-03 21:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: spice-protocol-0.12.11-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1264102 1264105 1264107 (view as bug list)
Environment:
Last Closed: 2016-11-03 21:09:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victor Toso 2015-09-17 10:00:40 EDT
This bug was initially created as a clone of Bug #1012868 but for RHEL 7

The volume-sync feature to synchronization volume from client to guest needs patches in 4 different components:
spice-protocol, spice-server, spice-gtk and spice-vdagent

spice-protocol:
  * add volume synchronization to protocol
    9acfaa66df90cb1475db7c09da09b6e9b5f5dd00

spice-server:
  * sound: do not modify client state on migration
    f10de4bc084fcc653340545b53782c8c4b660ea9

spice-gtk:
  * audio: Do not volume-sync without audio
    a99ed1524b075c0cd9e7d82e7877783a1e31d291

  * agent: sync guest audio with client values
    8c50e1a2b9f243a7da9b538cc1438b6a9d8e5671

  * audio: spice-gstaudio implements async volume-info
    aa8d044417bbf60685f59163b874ecb4f157c3c9

  * audio: spice-pulse implement async volume-info
    37ba949716ebf4411103308f4dbde75e81c7a9b3

  * audio: spice-audio with get mute and volume
    29a6a342da427005c1f84c705a9435535c26d5e9

spice-vdagent:
  * audio: add functions to set volume/mute with alsa
    010dc21f35fb3997ade6717e10c6a3b52a1737ba

  * vdagent: volume synchronization from client.
    9b0eb8b1246ccb422ccecc3679b0bb6b477ba6cb

  * vdagentd-proto-strings: Add missing string for VDAGENTD_AUDIO_VOLUME_SYNC
    536b63cfaf53aaaa8ef7395a998338ef23f514ae
Comment 3 Mike McCune 2016-03-28 19:43:17 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 errata-xmlrpc 2016-11-03 21:09:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html

Note You need to log in before you can comment on or make changes to this bug.