This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1264276 - [abrt] fedpkg: proxyclient.py:67:<module>:ImportError: No module named requests
[abrt] fedpkg: proxyclient.py:67:<module>:ImportError: No module named requests
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-fedora (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Infrastructure SIG
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:38433f23f46cdf9ae006706e083...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 01:40 EDT by Petr Lautrbach
Modified: 2016-05-10 13:54 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-fedora-0.8.0-1.fc23 python-fedora-0.8.0-1.fc24 python-fedora-0.8.0-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-25 19:52:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.23 KB, text/plain)
2015-09-18 01:40 EDT, Petr Lautrbach
no flags Details
File: dso_list (100 bytes, text/plain)
2015-09-18 01:40 EDT, Petr Lautrbach
no flags Details
File: environ (2.48 KB, text/plain)
2015-09-18 01:40 EDT, Petr Lautrbach
no flags Details

  None (edit)
Description Petr Lautrbach 2015-09-18 01:40:07 EDT
Description of problem:
I've tried to make an srpm using command:
$ fedpkg srpm

Version-Release number of selected component:
fedpkg-1.20-2.fc24

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /usr/bin/fedpkg srpm
executable:     /usr/bin/fedpkg
kernel:         4.3.0-0.rc0.git14.2.fc24.x86_64
runlevel:       N 5
type:           Python
uid:            13558

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/fedora/client/proxyclient.py:67
#2 <module> in /usr/lib/python2.7/site-packages/fedora/client/__init__.py:121
#3 <module> in /usr/lib/python2.7/site-packages/fedora_cert/__init__.py:15
#4 <module> in /usr/lib/python2.7/site-packages/pkgdb2client/__init__.py:27
#5 <module> in /usr/lib/python2.7/site-packages/fedpkg/cli.py:21
#6 <module> in /usr/lib/python2.7/site-packages/fedpkg/__init__.py:14
#7 <module> in /usr/bin/fedpkg:13
Comment 1 Petr Lautrbach 2015-09-18 01:40:10 EDT
Created attachment 1074685 [details]
File: backtrace
Comment 2 Petr Lautrbach 2015-09-18 01:40:12 EDT
Created attachment 1074686 [details]
File: dso_list
Comment 3 Petr Lautrbach 2015-09-18 01:40:13 EDT
Created attachment 1074687 [details]
File: environ
Comment 4 Petr Lautrbach 2015-09-21 06:58:26 EDT
Apparently, the package doesn't require python-requests.noarch. 
'dnf install python-requests.noarch' fixes this problem
Comment 5 Petr Lautrbach 2015-09-21 07:04:18 EDT

*** This bug has been marked as a duplicate of bug 1264426 ***
Comment 6 Petr Lautrbach 2015-09-21 07:24:27 EDT
It turned out that it's actually bug in python-fedora which does 'import request' but doesn't require python-requests package.
Comment 7 Petr Lautrbach 2015-09-21 07:37:21 EDT
So it was a bug in python3-request which was set to provide python-request. It
should be fixed python-requests-2.7.0-5.fc23, see
https://bugzilla.redhat.com/show_bug.cgi?id=1241671
Comment 8 Jan Kurik 2016-02-24 08:45:53 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 9 Fedora Update System 2016-04-24 06:26:53 EDT
python-fedora-0.8.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-258acdf02e
Comment 10 Fedora Update System 2016-04-24 06:27:20 EDT
python-fedora-0.8.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-809a11ce4e
Comment 11 Fedora Update System 2016-04-24 06:27:38 EDT
python-fedora-0.8.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c1dfe08924
Comment 12 Fedora Update System 2016-04-24 12:50:04 EDT
python-fedora-0.8.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-809a11ce4e
Comment 13 Fedora Update System 2016-04-24 20:20:49 EDT
python-fedora-0.8.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c1dfe08924
Comment 14 Fedora Update System 2016-04-24 20:23:07 EDT
python-fedora-0.8.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-258acdf02e
Comment 15 Fedora Update System 2016-04-25 19:51:57 EDT
python-fedora-0.8.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2016-05-07 07:57:09 EDT
python-fedora-0.8.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-05-10 13:54:04 EDT
python-fedora-0.8.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.