Bug 1264426 - [abrt] copr-cli: __init__.py:839:resolve:DistributionNotFound: The 'requests' distribution was not found and is required by copr
[abrt] copr-cli: __init__.py:839:resolve:DistributionNotFound: The 'requests'...
Status: CLOSED DUPLICATE of bug 1241671
Product: Fedora
Classification: Fedora
Component: python-copr (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:01148923a20d151573fb8f7ec8c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 08:43 EDT by Petr Lautrbach
Modified: 2015-10-14 06:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 06:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.97 KB, text/plain)
2015-09-18 08:43 EDT, Petr Lautrbach
no flags Details
File: environ (2.46 KB, text/plain)
2015-09-18 08:43 EDT, Petr Lautrbach
no flags Details

  None (edit)
Description Petr Lautrbach 2015-09-18 08:43:51 EDT
Description of problem:
run copr-cli

Version-Release number of selected component:
copr-cli-1.44-2.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python2 /usr/bin/copr-cli
dso_list:       python-setuptools-18.3.1-1.fc24.noarch
executable:     /usr/bin/copr-cli
kernel:         4.3.0-0.rc0.git14.2.fc24.x86_64
runlevel:       N 5
type:           Python
uid:            13558

Truncated backtrace:
__init__.py:839:resolve:DistributionNotFound: The 'requests' distribution was not found and is required by copr

Traceback (most recent call last):
  File "/usr/bin/copr-cli", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 651, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 952, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
DistributionNotFound: The 'requests' distribution was not found and is required by copr

Local variables in innermost frame:
dist: None
requirers: set(['copr'])
to_activate: [copr-cli 0.3.0 (/usr/lib/python2.7/site-packages), copr 0.0.1 (/usr/lib/python2.7/site-packages), six 1.9.0 (/usr/lib/python2.7/site-packages)]
req: Requirement.parse('requests')
requirements: []
new_requirements: []
replace_conflicting: False
required_by: defaultdict(<type 'set'>, {Requirement.parse('six'): set(['copr']), Requirement.parse('copr'): set(['copr-cli']), Requirement.parse('requests'): set(['copr'])})
ws: <pkg_resources.WorkingSet object at 0x7f0a05d9cb90>
new_requirement: Requirement.parse('requests')
env: <pkg_resources.Environment object at 0x7f0a05d9cbd0>
installer: None
self: <pkg_resources.WorkingSet object at 0x7f0a05d9cb90>
best: {'requests': None}
processed: {Requirement.parse('six'): True, Requirement.parse('copr-cli==0.3.0'): True, Requirement.parse('copr'): True}
Comment 1 Petr Lautrbach 2015-09-18 08:43:54 EDT
Created attachment 1074857 [details]
File: backtrace
Comment 2 Petr Lautrbach 2015-09-18 08:43:55 EDT
Created attachment 1074858 [details]
File: environ
Comment 3 Petr Lautrbach 2015-09-21 06:58:01 EDT
Apparently, the package doesn't require python-requests.noarch. 
'dnf install python-requests.noarch' fixes this problem
Comment 4 Petr Lautrbach 2015-09-21 07:04:14 EDT
*** Bug 1264309 has been marked as a duplicate of this bug. ***
Comment 5 Petr Lautrbach 2015-09-21 07:04:18 EDT
*** Bug 1264276 has been marked as a duplicate of this bug. ***
Comment 6 Petr Lautrbach 2015-09-21 07:04:37 EDT
$ python                           
Python 2.7.10 (default, Sep  3 2015, 20:12:09) 
[GCC 5.1.1 20150618 (Red Hat 5.1.1-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import bugzilla
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/bugzilla/__init__.py", line 22, in <module>
    from .base import BugzillaBase as _BugzillaBase
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 34, in <module>
    import requests
ImportError: No module named requests


$ rpm -qf /usr/lib/python2.7/site-packages/bugzilla/base.py
python-bugzilla-1.2.1-2.fc23.noarch
Comment 7 Petr Lautrbach 2015-09-21 07:35:51 EDT
So it was a bug in python3-request which was set to provide python-request. It should be fixed python-requests-2.7.0-5.fc23, see https://bugzilla.redhat.com/show_bug.cgi?id=1241671
Comment 8 Jakub Kadlčík 2015-10-14 06:15:09 EDT

*** This bug has been marked as a duplicate of bug 1241671 ***

Note You need to log in before you can comment on or make changes to this bug.