Bug 1264441 - Data Tiering:Regression:Detach tier commit is passing when detach tier is in progress
Data Tiering:Regression:Detach tier commit is passing when detach tier is in ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On:
Blocks: 1278390 1279637
  Show dependency treegraph
 
Reported: 2015-09-18 09:20 EDT by nchilaka
Modified: 2016-04-19 03:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1278390 1279637 (view as bug list)
Environment:
Last Closed: 2016-04-19 03:47:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nchilaka 2015-09-18 09:20:24 EDT
when detach tier is in progress, detach tier commit must not be allowed.
This was working well previously. This means it is a regression,
Could be due to fix for bz#1259694


glusterfs-server-3.7.4-0.33.git1d02d4b.el7.centos.x86_64


Steps to Reproduce:
====================
1.create a volume, start it and attac tier to vol  and create lot of data on hot tier
2.now issue a detach-tier <vname> start
3. While it is in progress,issue a detach-tier <vname> commit
Comment 1 nchilaka 2015-09-18 09:21:39 EDT
this wasfound during automation of qe scripts
Comment 2 Dan Lambright 2015-09-30 15:36:21 EDT
have done a RCA on this and will begin working on a fix.
Comment 3 Dan Lambright 2015-10-01 11:14:45 EDT
submitted fix 12272
Comment 4 Vijay Bellur 2015-10-28 12:44:33 EDT
REVIEW: http://review.gluster.org/12272 (cluster/tier: migration daemon incorrectly signals detach tier done) posted (#3) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)
Comment 5 Vijay Bellur 2015-10-28 16:31:24 EDT
REVIEW: http://review.gluster.org/12272 (cluster/tier: Disallow detach commit when detach in progress) posted (#4) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)
Comment 6 Vijay Bellur 2015-11-16 08:18:59 EST
COMMIT: http://review.gluster.org/12272 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 3a13092cb001b1a998268a2cdb0056615ece1d54
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Thu Oct 1 11:05:25 2015 -0400

    cluster/tier: Disallow detach commit when detach in progress
    
    1. Check if detach is running, disallow detach commit if so.
    2. Cleanup shutdown of tier daemon on detach: do not rerun fix-layout,
       do not send incorrect status back to glusterd.
    
    Change-Id: I97202f748773c1176396a4ffd32a4c7fa9b9c1bc
    BUG: 1264441
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12272
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
Comment 7 Kaushal 2016-04-19 03:47:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.