Bug 1264572 - periodically a user gets logged out and cannot log back in (horizon)
periodically a user gets logged out and cannot log back in (horizon)
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity medium
: ---
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 16:43 EDT by Freddy Wissing
Modified: 2016-02-18 10:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 10:20:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Freddy Wissing 2015-09-18 16:43:31 EDT
Description of problem:

Every 10-60 minutes a user gets logged out and referred back to the login screen.  At this point, every subsequent login attempt with proper creds fails.

Version-Release number of selected component (if applicable):

Openstack 7.0

How reproducible:

Not immediately reproducible.

The customer says that by opening up a private window each time this occurs, the logins are then accepted.   They can also delete the cookies and then it works.


Actual results:  Logins attempts only result in being sent back to the login screen.  


Expected results:  Login. 


External tracker:  

https://review.openstack.org/#/c/222478/
Comment 2 Sascha Spreitzer (Red Hat) 2015-09-22 04:55:30 EDT
I can confirm this on my rdo kilo installation.

External has merged the fix.
Comment 3 Matthias Runge 2015-09-22 04:59:35 EDT
(In reply to Sascha Spreitzer from comment #2)
> I can confirm this on my rdo kilo installation.
> 
> External has merged the fix.

Cases are different. If I understand you right, you can not log in any more after being logged out. For that issue, one of two patches were merged upstream. 

This is not an problem for RHOS, since that includes already a fix for that "value must be integer" issue.
Comment 5 Matthias Runge 2015-12-01 02:26:47 EST
I believe, this is due to a mis-configuration.

Session cookies become quite big; My assumption is, they get too big.
The situation becomes worse, when lots of services are enabled (service catalog is stored in cookie, or when using PKI tokens)

Changing session engine

SESSION_ENGINE='django.contrib.sessions.backends.cache'

in /etc/openstack-dashboard/local_settings

and taking care, there is a cache like memcached enabled solved this issue for me.

FWIW, I filed a bug on openstack-puppet-modules to fix this some time ago:
https://bugzilla.redhat.com/show_bug.cgi?id=1255369
Comment 6 Matthias Runge 2016-02-18 10:20:48 EST
We're already carrying the mentioned fix for a long time. I'm closing this bug, as I wasn't able to reproduce at all, and I haven't seen any other reports of this.

Please re-open, if you can reproduce.

Note You need to log in before you can comment on or make changes to this bug.