Bug 1264694 - New ginac 1.6.5 breaks dependency
New ginac 1.6.5 breaks dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ginac (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
: 1269708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-20 15:48 EDT by pkoz
Modified: 2015-10-08 15:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 15:51:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pkoz 2015-09-20 15:48:27 EDT
Description of problem:
octave-symbolic.x86_64 1.1.0-9.fc22 depends on libginac.so.4.
libginac.so.4 is included in ginac.x86_64 1.6.3-1.fc22, which is fine.
New package ginac.x86_64 1.6.5-1.fc22 includes libginac.so.5 instead of libginac.so.4.

Now, I cannot update ginac without removing octave-symbolic.

Version-Release number of selected component (if applicable):
ginac.x86_64 1.6.5-1.fc22
octave-symbolic.x86_64 1.1.0-9.fc22

How reproducible:
dnf update complains like this:
Skipping packages with broken dependencies:
 ginac          x86_64          1.6.5-1.fc22             updates          962 k

Steps to Reproduce:
1. run dnf update  when octave-sumbolic and ginac are installed
2.
3.

Actual results:
ginac is not updated

Expected results:
ginac gets updated

Additional info:
Comment 1 Fedora Update System 2015-09-20 20:34:50 EDT
octave-symbolic-1.1.0-10.fc22 orsa-0.7.0-31.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16264
Comment 2 Fedora Update System 2015-09-21 14:22:12 EDT
octave-symbolic-1.1.0-10.fc22, orsa-0.7.0-31.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update orsa octave-symbolic'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16264
Comment 3 Thomas Sailer 2015-10-08 03:15:49 EDT
*** Bug 1269708 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2015-10-08 15:51:36 EDT
octave-symbolic-1.1.0-10.fc22, orsa-0.7.0-31.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.