Bug 126472 - status window should be hidden when the window is minimized
status window should be hidden when the window is minimized
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-06-22 03:46 EDT by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-29 21:57:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot when the window is minimized after activating IM (359.87 KB, image/png)
2004-06-23 02:28 EDT, Akira TAGOH
no flags Details
latest rawhide 12.0 in KDE 3.2 (139.37 KB, image/png)
2004-08-26 23:37 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Akira TAGOH 2004-06-22 03:46:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
on the applications which needs httx, even if the window is minimized,
the status window still appears. since the status window is auxiliary
for the input method, it should be hidden.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run kedit
2.activate the IM
3.minimize kedit window
    

Actual Results:  kedit's window is minimized. but the status window
still appears and is kept on the same place.

Expected Results:  the status window should disappears with minimized
window.

Additional info:
Comment 1 Yu Shao 2004-06-22 21:05:48 EDT
I tested found httx is handling status window correctly, but iiimgcf
doesn't, can you confirm it again? Patch for iiimgcf would be simple
though.
Comment 2 Akira TAGOH 2004-06-23 02:28:17 EDT
Created attachment 101351 [details]
screenshot when the window is minimized after activating IM

correctly? are you sure? I tested this on -60. as you can see from the
screenshot, the status window still appears when the window is even minimized.
Comment 3 Akira TAGOH 2004-06-23 02:32:30 EDT
related problem: even if the window is missing the focus, the status
window still appears. this issue doesn't happen on gtk2 applications.
basically when the window is minimized, the minimized window is
missing the focus. so this case is same as the original problem.
Comment 4 Lawrence Lim 2004-06-23 02:53:01 EDT
I can reproduce the problem in KDE and the bug still exist.
In GNOME however, I tried to run application such as kedit and change
Input Method for g-t to XIM, everything look ok.
Comment 5 Lawrence Lim 2004-07-05 01:03:17 EDT
Tested with latest stable -46.svn1587 in KDE, problem still exist.
Comment 6 Akira TAGOH 2004-08-06 06:11:06 EDT
tested with -68.svn1833 and confirmed fix. we should make the updated
package for FC2 updates since this bug is for FC2.
Comment 7 Lawrence Lim 2004-08-26 23:37:07 EDT
Created attachment 103152 [details]
latest rawhide 12.0 in KDE 3.2

The status window is hidden when the application is minimised in the KDE
environment. However, if you toggle on the LE, and click the Close (X) button
of the application, the status window will still be visible. 

I am happy to close this bug and file another bug if you think the situation
described is not related to this bug.
Comment 8 Akira TAGOH 2004-08-27 01:30:31 EDT
Yeah, it should be separated. please do so.
Comment 9 Lawrence Lim 2004-08-29 21:57:04 EDT
Confirmed fix in rawhide (im-sdk-12.0.1-1).

New bug 131211 filed.

Note You need to log in before you can comment on or make changes to this bug.