Bug 131211 - status window should be destroyed after closing application
Summary: status window should be destroyed after closing application
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: IIIMF
TreeView+ depends on / blocked
 
Reported: 2004-08-30 01:55 UTC by Lawrence Lim
Modified: 2014-03-26 00:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 02:43:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot in KDE (139.37 KB, image/png)
2004-08-30 01:57 UTC, Lawrence Lim
no flags Details
IIIMF in the KDE desktop (271.00 KB, image/png)
2004-10-12 08:03 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2004-08-30 01:55:45 UTC
Description of problem:
In the KDE environment, the status window for status window is not
destoryed after clicking the close button (X) button. In the GNOME
environment, it works fine for KDE applications such as kedit. Very
similar behaviour to bug 126472.

Version-Release number of selected component (if applicable):
- KDE 3.2
- im-sdk-12.0.1-1.svn1891

How reproducible:
Always

Steps to Reproduce:
1.Choose CJK and KDE session at gdm
2.Alt+F2 
3.Toggle on LE
4.Click on the close (X) button
  
Actual results:
Status window remains on the desktop after the application is closed.

Expected results:
Status window destroyed when the application is closed.

Additional info:
Verified with ja_JP and zh_TW locale

Comment 1 Lawrence Lim 2004-08-30 01:57:43 UTC
Created attachment 103225 [details]
screenshot in KDE

Comment 2 Yu Shao 2004-10-11 06:20:38 UTC
confirm fixed.

Comment 3 Lawrence Lim 2004-10-12 08:01:19 UTC
Tested im-sdk-12.0.1-13.svn1943 in KDE3.3 and this is how I can
reproduce the problem again.

Please try it with these steps:
1. in gdm login as simplified chinese / kde session
2. after run kde, press alt-f2 to run dialog
3. ctrl-space to activiate LE
4. press escape

Actual result
the status window still remains

Attached is the screenshot of the result




Comment 4 Lawrence Lim 2004-10-12 08:03:43 UTC
Created attachment 105051 [details]
IIIMF in the KDE desktop

Comment 5 Lawrence Lim 2004-10-19 08:03:07 UTC
Bug still exist in im-sdk-12.1-1.

Comment 6 Akira TAGOH 2005-05-09 10:50:47 UTC
Is this problem still reproducible?

Comment 7 Akira TAGOH 2005-05-09 11:00:04 UTC
erm, I could. it's still there.

Comment 9 Akira TAGOH 2005-09-27 02:43:15 UTC
this is necessary to be investigated in upstream so that this is the general
issues related to the auxiliary handling. so I'm closing this since there is a
workaround to destroy the process with restarting the desktop session.


Note You need to log in before you can comment on or make changes to this bug.