Bug 1264889 - [abrt] taskcoach: _windows.py:4:<module>:ImportError: /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_windows_.so: symbol _ZThn696_N13wxHtmlListBox10RefreshAllEv, version WXU_3.0 not defined in file libwx_gtk3u_html-3.0.so.0 with link time reference
[abrt] taskcoach: _windows.py:4:<module>:ImportError: /usr/lib64/python2.7/si...
Status: CLOSED DUPLICATE of bug 1268984
Product: Fedora
Classification: Fedora
Component: wxGTK3 (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeremy Newton
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ddc8f7e3e79f751d8da72693b40...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 08:21 EDT by Vaso VV
Modified: 2015-10-30 21:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 21:08:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.51 KB, text/plain)
2015-09-21 08:21 EDT, Vaso VV
no flags Details
File: environ (3.50 KB, text/plain)
2015-09-21 08:21 EDT, Vaso VV
no flags Details

  None (edit)
Description Vaso VV 2015-09-21 08:21:00 EDT
Description of problem:
Taskcoach doesn't start

Version-Release number of selected component:
taskcoach-1.4.2-2.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /bin/taskcoach
dso_list:       wxPython-3.0.2.0-6.fc23.x86_64
executable:     /bin/taskcoach
kernel:         4.2.0-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_windows.py:4
#2 <module> in /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16921
#3 <module> in /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/__init__.py:45
#4 <module> in /usr/lib/python2.7/site-packages/taskcoachlib/operating_system.py:19
#5 <module> in /usr/lib/python2.7/site-packages/taskcoachlib/config/settings.py:19
#6 <module> in /usr/lib/python2.7/site-packages/taskcoachlib/config/__init__.py:19
#7 start in /bin/taskcoach:61
#8 <module> in /bin/taskcoach:72
Comment 1 Vaso VV 2015-09-21 08:21:05 EDT
Created attachment 1075490 [details]
File: backtrace
Comment 2 Vaso VV 2015-09-21 08:21:06 EDT
Created attachment 1075491 [details]
File: environ
Comment 3 Marek Pikuła 2015-10-08 13:18:26 EDT
The same happens with playonlinux from playonlinux repo https://paste.fedoraproject.org/276537/
Comment 4 Scott Talbert 2015-10-29 20:15:11 EDT
For anyone that can reproduce this, can you please run these commands and provide the output:

readelf -Ws /usr/lib64/libwx_gtk3u_html-3.0.so.0 | grep _ZThn696_N13wxHtmlListBox10RefreshAllEv

rpm -q wxGTK3
Comment 5 Scott Talbert 2015-10-30 21:08:01 EDT

*** This bug has been marked as a duplicate of bug 1268984 ***

Note You need to log in before you can comment on or make changes to this bug.