Bug 1268984 - wx gtk3 link error - upgrade path issue
wx gtk3 link error - upgrade path issue
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wxGTK3 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeremy Newton
Fedora Extras Quality Assurance
:
: 1264889 1275368 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 16:03 EDT by chedi toueiti
Modified: 2015-11-16 12:33 EST (History)
12 users (show)

See Also:
Fixed In Version: wxGTK3-3.0.2-11.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-08 17:20:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of 'dnf distro-sync' (3.03 KB, text/plain)
2015-10-14 07:41 EDT, IanB
no flags Details

  None (edit)
Description chedi toueiti 2015-10-05 16:03:21 EDT
Description of problem:
After updating my fedora 22 install to 23 Beta I had this problem with filezilla

Version-Release number of selected component (if applicable):
23 beta

How reproducible:
every tiume

Steps to Reproduce:
1.start filezilla
2.
3.

Actual results:

filezilla: relocation error: filezilla: symbol _ZThn792_N17wxGenericListCtrl31GetSizeAvailableForScrollTargetERK6wxSize, version WXU_3.0 not defined in file libwx_gtk3u_core-3.0.so.0 with link time reference


Expected results:


Additional info:
Comment 1 IanB 2015-10-05 23:08:25 EDT
I'm having the same issue. There is an upstream bug report here which may be relevant: https://trac.filezilla-project.org/ticket/9394
Comment 2 Design Software 2015-10-10 12:33:28 EDT
I can also confirm the bug when running filezilla

$ filezilla
filezilla: relocation error: filezilla: symbol _ZThn792_N17wxGenericListCtrl31GetSizeAvailableForScrollTargetERK6wxSize, version WXU_3.0 not defined in file libwx_gtk3u_core-3.0.so.0 with link time reference
Comment 3 Nicolas Chauvet (kwizart) 2015-10-14 06:20:35 EDT
I don't reproduce with a new f23 installation
Can you run dnf distro-sync and tell me which packages got listed ?
Comment 4 IanB 2015-10-14 07:41 EDT
Created attachment 1082795 [details]
Output of 'dnf distro-sync'
Comment 5 chedi toueiti 2015-10-14 08:02:22 EDT
the distro-sync fixed the issue by upgrading the wx* packages

 wxBase3                                                x86_64                               3.0.2-8.fc23                                   fedora                                       1.1 M
 wxGTK3                                                 x86_64                               3.0.2-8.fc23                                   fedora                                       5.4 M
 wxGTK3-gl                                              x86_64                               3.0.2-8.fc23                                   fedora                                        35 k
 wxGTK3-media                                           x86_64                               3.0.2-8.fc23                                   fedora                                        56 k


Thanks
Comment 6 Nicolas Chauvet (kwizart) 2015-10-14 08:11:03 EDT
It's an issue with wxGTK3 been newer in f22 than in f23
Doing a scratch build for f23 (previously it has failed in f23/f24):
http://koji.fedoraproject.org/koji/taskinfo?taskID=11443292
Comment 7 Nicolas Chauvet (kwizart) 2015-10-14 08:17:51 EDT
looks like "No Package found for libgnomeprintui22-devel"
Comment 8 Christopher Meng 2015-10-14 08:42:03 EDT
(In reply to Nicolas Chauvet (kwizart) from comment #7)
> looks like "No Package found for libgnomeprintui22-devel"

It had been retired since f23.
Comment 9 Dandim 2015-10-15 07:46:32 EDT
I repaired this problem by these commands:

sudo dnf remove wxGTK3
sudo dnf install filezilla --allowerasing

After i run filezilla normally :-)
I think new package wxGTK3 from will repair it, until then you can use command above
Comment 10 Luya Tshimbalanga 2015-10-15 12:33:27 EDT
Will it possible to do the fix? I have Filezilla included in Design Suite.
Comment 11 Boricua 2015-10-18 10:26:53 EDT
(In reply to Dandim from comment #9)
> I repaired this problem by these commands:
> 
> sudo dnf remove wxGTK3
> sudo dnf install filezilla --allowerasing
> 
> After i run filezilla normally :-)
> I think new package wxGTK3 from will repair it, until then you can use
> command above

I had this same issue after upgrading from F22 to F23. These commands fixed it for me. Thanks.
Comment 12 Erik Johnson 2015-10-19 01:01:42 EDT
(In reply to Dandim from comment #9)
> I repaired this problem by these commands:
> 
> sudo dnf remove wxGTK3
> sudo dnf install filezilla --allowerasing
> 
> After i run filezilla normally :-)
> I think new package wxGTK3 from will repair it, until then you can use
> command above

What this did for me that the sysupgrade did not was downgrade wxBase3 to 3.0.2-8.fc23  
(also after re-installing other wx apps that got removed with your commands, there were several new depends installed that weren't removed.  hmmm)
Comment 13 Jeremy Newton 2015-10-20 11:26:35 EDT
I'll look into this on the weekend. I must have overlooked this when I ran the last build.
Comment 14 Scott Talbert 2015-10-30 21:08:01 EDT
*** Bug 1264889 has been marked as a duplicate of this bug. ***
Comment 15 Scott Talbert 2015-10-30 21:09:08 EDT
*** Bug 1275368 has been marked as a duplicate of this bug. ***
Comment 16 Scott Talbert 2015-10-30 21:17:53 EDT
Jeremy, it seems to build fine without the BR: libgnomeprintui22-devel, so removing that should be the only change needed to fix it.
Comment 17 Marek Pikuła 2015-10-31 15:37:58 EDT
After running `dnf install wxGTK3-3.0.2-8.fc23.x86_64 --allowerasing` everything works (filezilla and playonlinux).
Comment 18 Jeremy Newton 2015-11-01 08:23:37 EST
(In reply to Scott Talbert from comment #16)
> Jeremy, it seems to build fine without the BR: libgnomeprintui22-devel, so
> removing that should be the only change needed to fix it.

I sent a build out, I'll tag this bug with the update if it works.
Comment 19 Fedora Update System 2015-11-01 09:06:29 EST
wxGTK3-3.0.2-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f8ee2ffc06
Comment 20 Fedora Update System 2015-11-01 19:49:04 EST
wxGTK3-3.0.2-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update wxGTK3'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f8ee2ffc06
Comment 21 Fedora Update System 2015-11-05 21:48:37 EST
wxGTK3-3.0.2-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-aafbcfb7d7
Comment 22 Fedora Update System 2015-11-08 08:25:13 EST
wxGTK3-3.0.2-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update wxGTK3'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-aafbcfb7d7
Comment 23 Fedora Update System 2015-11-08 17:20:11 EST
wxGTK3-3.0.2-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 24 Vaso VV 2015-11-16 11:53:16 EST
$ rpm -q wxGTK3
wxGTK3-3.0.2-11.fc23.x86_64

$ readelf -Ws /usr/lib64/libwx_gtk3u_html-3.0.so.0 | grep _ZThn696_N13wxHtmlListBox10RefreshAllEv
 1659: 00000000000bade0     9 FUNC    GLOBAL DEFAULT   12 _ZThn696_N13wxHtmlListBox10RefreshAllEv@@WXU_3.0

$ taskcoach
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_set_qdata: assertion 'node != NULL' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: cannot register existing type 'GtkWidget'
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: cannot register existing type 'GtkBuildable'
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_once_init_leave: assertion 'result != 0' failed
  from gtk import _gtk
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_register_static: assertion 'parent_type > 0' failed
  from gtk import _gtk
Comment 25 Scott Talbert 2015-11-16 12:33:48 EST
(In reply to Vaso VV from comment #24)
> $ rpm -q wxGTK3
> wxGTK3-3.0.2-11.fc23.x86_64
> 
> $ readelf -Ws /usr/lib64/libwx_gtk3u_html-3.0.so.0 | grep
> _ZThn696_N13wxHtmlListBox10RefreshAllEv
>  1659: 00000000000bade0     9 FUNC    GLOBAL DEFAULT   12
> _ZThn696_N13wxHtmlListBox10RefreshAllEv@@WXU_3.0
> 
> $ taskcoach
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
> g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed
>   from gtk import _gtk
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
> g_type_set_qdata: assertion 'node != NULL' failed
>   from gtk import _gtk
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
> cannot register existing type 'GtkWidget'
>   from gtk import _gtk
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
> g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE
> (instance_type)' failed
>   from gtk import _gtk
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
> cannot register existing type 'GtkBuildable'
>   from gtk import _gtk
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
> g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE
> (interface_type)' failed
>   from gtk import _gtk
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
> g_once_init_leave: assertion 'result != 0' failed
>   from gtk import _gtk
> /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: Warning:
> g_type_register_static: assertion 'parent_type > 0' failed
>   from gtk import _gtk

That's https://bugzilla.redhat.com/show_bug.cgi?id=1187849.  Fix coming soon to stable.

Note You need to log in before you can comment on or make changes to this bug.