Bug 1265176 - [7.1-3.5.5] Auto-install failed with rhn registration
Summary: [7.1-3.5.5] Auto-install failed with rhn registration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Ryan Barry
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1273075
TreeView+ depends on / blocked
 
Reported: 2015-09-22 10:02 UTC by Huijuan Zhao
Modified: 2016-03-09 14:39 UTC (History)
10 users (show)

Fixed In Version: ovirt-node-3.3.0-0.16.20151021git51ae965.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1273075 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:39:12 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
auto install error screenshot (3.41 MB, image/jpeg)
2015-09-22 10:02 UTC, Huijuan Zhao
no flags Details
auto install error log (5.20 MB, application/x-gzip)
2015-09-22 10:04 UTC, Huijuan Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 46537 master MERGED Set rhn_type in rhn_autoinstall if it's None so it works on EL7 Never
oVirt gerrit 46748 ovirt-3.6 MERGED Set rhn_type in rhn_autoinstall if it's None so it works on EL7 Never
oVirt gerrit 47164 ovirt-3.5 MERGED Set rhn_type in rhn_autoinstall if it's None so it works on EL7 Never

Description Huijuan Zhao 2015-09-22 10:02:37 UTC
Created attachment 1075757 [details]
auto install error screenshot

Description of problem:
Auto-install failed with rhn registration


Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.1-20150917.0.e17ev
ovirt-node-3.2.3-20.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Auto install RHEVH with the follow parameters.
BOOTIF=01-b8-ca-3a-a9-91-70 storage_init=/dev/sda rhn_username=*** rhn_password=*** adminpw=OKr05SbCu3D3g firstboot  

Actual results:
After step1, during installing, An error appeared(such as screenshot on attach), auto install failed.

Expected results:
After step1, auto install should success.

Additional info:
also encounter this issue on rhev-hypervisor-7-7.1-20150827.1.e17ev

Comment 1 Huijuan Zhao 2015-09-22 10:04:26 UTC
Created attachment 1075758 [details]
auto install error log

Comment 2 Huijuan Zhao 2015-09-22 10:28:39 UTC
add Keywords TestBlocker due to block auto install with rhn registration

Comment 3 Ryan Barry 2015-09-22 16:37:10 UTC
I tested all the way back to the first EL7 RHEV-H images. This has never worked, and it appears to be due to same explanation as bz#906875.

rhn_autoinstall should be using subscription-manager on EL7, and it wasn't.

Comment 7 Huijuan Zhao 2015-10-13 09:48:25 UTC
Fabian, I also encounter this issue on build: rhev-hypervisor7-7.2-20151009.0.iso.
Could you provide which build should I use to verify this issue? Thanks.

Comment 8 Ryan Barry 2015-10-13 22:02:36 UTC
(In reply to Huijuan Zhao from comment #7)
> Fabian, I also encounter this issue on build:
> rhev-hypervisor7-7.2-20151009.0.iso.
> Could you provide which build should I use to verify this issue? Thanks.

I believe you're now encountering bz#1259499 (or I did when I tested).

Once that bug can be verified (SAM on 3.6), this will also work. The correct code path is now being triggered, just a different bug.

Comment 10 Huijuan Zhao 2015-11-12 12:02:11 UTC
It is blocked by Bug 1275222.
I will verify this issue after Bug 1275222 is fixed.

Comment 11 Huijuan Zhao 2015-12-02 06:57:20 UTC
Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20151201.1.e17ev
ovirt-node-3.6.0-0.23.20151201git5eed7af.el7ev.noarch

Test Steps:
1. Auto install RHEVH with the follow parameters.
BOOTIF=01-b8-ca-3a-a9-91-70 storage_init=/dev/sda rhn_username=*** rhn_password=*** adminpw=OKr05SbCu3D3g firstboot  

Test results:
After step1, auto install successful.


So this bug is fixed on rhev-hypervisor-7-7.2-20151201.1.e17ev, I will change the status to verified.

Comment 13 errata-xmlrpc 2016-03-09 14:39:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.