Bug 1265209 - [7.1_3.5.5] Auto-install with wrong BOOTIF parameter enter to dracut
[7.1_3.5.5] Auto-install with wrong BOOTIF parameter enter to dracut
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.5
Unspecified Unspecified
high Severity medium
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Fabian Deutsch
Huijuan Zhao
node
:
: 1264049 (view as bug list)
Depends On:
Blocks: 1264358
  Show dependency treegraph
 
Reported: 2015-09-22 07:45 EDT by Huijuan Zhao
Modified: 2016-02-10 14:18 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 06:56:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of enter to dracut (2.74 MB, image/jpeg)
2015-09-22 07:45 EDT, Huijuan Zhao
no flags Details
rdsosreport.txt (85.42 KB, text/plain)
2015-09-22 07:46 EDT, Huijuan Zhao
no flags Details

  None (edit)
Description Huijuan Zhao 2015-09-22 07:45:11 EDT
Created attachment 1075785 [details]
screenshot of enter to dracut

Description of problem:
Auto-install with wrong BOOTIF parameter enter to dracut, and if field in "exit" on the shell, install can continue and install successfully.


Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.1-20150917.0.e17ev
ovirt-node-3.2.3-20.el7.noarch
dracut-033-241.el7_1.5.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Auto install RHEVH with the follow parameters.
BOOTIF=em2 storage_init=/dev/sda adminpw=OKr05SbCu3D3g firstboot (note:actually there is no em2 on machine)


Actual results:
After step1, enter to dracut(such as screenshot in attach), and if field in "exit" on the shell, install can continue and install successfully.

Expected results:
After step1, auto install should enter to shell with prompt message due to wrong BOOTIF parameter, and can not continue installation.

Additional info:
Comment 1 Huijuan Zhao 2015-09-22 07:46 EDT
Created attachment 1075789 [details]
rdsosreport.txt
Comment 2 Fabian Deutsch 2015-09-22 08:18:29 EDT
Adjusting priorities, because this is an unusual flow, and has no impact on runtime, it just prevents auto-install.
Comment 3 cshao 2015-10-16 08:11:04 EDT
*** Bug 1264049 has been marked as a duplicate of this bug. ***
Comment 4 Huijuan Zhao 2015-10-20 03:59:42 EDT
Adjusting priorities, because encounter this issue on rhev-hypervisor-7-7.2-20151009.0.e17ev,  and auto-install with usual kernel arguments:

BOOTIF=link storage_init=/dev/sda adminpw=OKr05SbCu3D3g firstboot
Comment 5 Fabian Deutsch 2015-10-20 06:56:58 EDT
RHEV-H is behaving like RHEL, thus I am closing this bug.

If oyu think this is an issue, please open a bug against platform dracut and describe the expected behavior.
Comment 6 Fabian Deutsch 2015-10-20 09:23:30 EDT
(In reply to Huijuan Zhao from comment #4)
> Adjusting priorities, because encounter this issue on
> rhev-hypervisor-7-7.2-20151009.0.e17ev,  and auto-install with usual kernel
> arguments:
> 
> BOOTIF=link storage_init=/dev/sda adminpw=OKr05SbCu3D3g firstboot

BOOTIF=link does not work on RHEV-H 7, this is a known limitation.
Please either use the macaddr or the nic name.

Note You need to log in before you can comment on or make changes to this bug.