Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1265238 - ss returns zero (ok) when invalid option is added
Summary: ss returns zero (ok) when invalid option is added
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Phil Sutter
QA Contact: Jaroslav Aster
URL:
Whiteboard:
Depends On:
Blocks: 1313485 1301628
TreeView+ depends on / blocked
 
Reported: 2015-09-22 12:53 UTC by Jaroslav Aster
Modified: 2016-11-03 23:34 UTC (History)
0 users

Fixed In Version: iproute-3.10.0-57.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1265240 (view as bug list)
Environment:
Last Closed: 2016-11-03 23:34:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2162 0 normal SHIPPED_LIVE iproute bug fix and enhancement update 2016-11-03 13:14:33 UTC

Description Jaroslav Aster 2015-09-22 12:53:08 UTC
Description of problem:

ss returns zero (ok) when invalid option is added.


Version-Release number of selected component (if applicable):

iproute-3.10.0-54.el7


How reproducible:

100%


Steps to Reproduce:

# ss --blabla && echo "OK" || echo "FAIL"
ss: unrecognized option '--blabla'
...
OK


Actual results:

Program returns zero.


Expected results:

Program returns non-zero.


Additional info:

Comment 1 Phil Sutter 2015-10-15 19:09:18 UTC
Bug is consistent with upstream, patch sent:

http://marc.info/?l=linux-netdev&m=144493568522690&w=2

Comment 2 Phil Sutter 2016-01-12 17:17:12 UTC
The following upstream commit needs to be backported:

commit f73105ab42795422f131fb711712e3c860df982f
Author: Phil Sutter <phil@nwl.cc>
Date:   Thu Oct 15 21:01:16 2015 +0200

    ss: return -1 if an unrecognized option was given
    
    When getopt_long encounters an option which has not been registered, it
    returns '?'. React upon that and call usage() instead of help() so ss
    returns with a non-zero exit status.
    
    Signed-off-by: Phil Sutter <phil@nwl.cc>

Comment 7 errata-xmlrpc 2016-11-03 23:34:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2162.html


Note You need to log in before you can comment on or make changes to this bug.