Bug 1265240 - ss returns zero (ok) when invalid option is added
ss returns zero (ok) when invalid option is added
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iproute (Show other bugs)
6.8
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Phil Sutter
Jaroslav Aster
:
Depends On:
Blocks: 1172231 1275424
  Show dependency treegraph
 
Reported: 2015-09-22 08:57 EDT by Jaroslav Aster
Modified: 2016-05-10 20:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: iproute-2.6.32-47.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1265238
Environment:
Last Closed: 2016-05-10 20:19:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Aster 2015-09-22 08:57:03 EDT
The same issue on rhel-6.

iproute-2.6.32-45.el6

+++ This bug was initially created as a clone of Bug #1265238 +++

Description of problem:

ss returns zero (ok) when invalid option is added.


Version-Release number of selected component (if applicable):

iproute-3.10.0-54.el7


How reproducible:

100%


Steps to Reproduce:

# ss --blabla && echo "OK" || echo "FAIL"
ss: unrecognized option '--blabla'
...
OK


Actual results:

Program returns zero.


Expected results:

Program returns non-zero.


Additional info:
Comment 1 Phil Sutter 2015-10-15 15:07:47 EDT
Bug is consistent with upstream, patch sent:

http://marc.info/?l=linux-netdev&m=144493568522690&w=2
Comment 6 errata-xmlrpc 2016-05-10 20:19:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0895.html

Note You need to log in before you can comment on or make changes to this bug.