Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1265395 - [xorg-x11-server] Xorg 1.18 unusable in a VM because of low responsiveness
Summary: [xorg-x11-server] Xorg 1.18 unusable in a VM because of low responsiveness
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-22 19:47 UTC by Joachim Frieben
Modified: 2015-09-26 03:10 UTC (History)
4 users (show)

Fixed In Version: 1.18.0-0.3.20150907.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-24 05:07:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Joachim Frieben 2015-09-22 19:47:04 UTC
Description of problem:
After upgrading the Xorg stack to ABI version 1.18, running X in a virtual machine is essentially impossible because of low responsiveness.

Version-Release number of selected component (if applicable):
xorg-x11-server-1.18.0-0.2.20150907.fc23

How reproducible:
Always.

Steps to Reproduce:
1. Launch a GNOME session in a VM.

Actual results:
Flickering screen, huge latencies of screen refresh and X input actions.

Expected results:
Normal behaviour.

Additional info:
- X used to behave as expected for ABI version 1.17 as can be verified by downgrading the Xorg stack.
- The QXL driver package which is used by gnome-boxes has only been rebuilt for ABI version 1.18 but not updated itself.
- The issue is possibly rather related to the X driver packages handling mouse and keyboard events.

Comment 1 Dave Airlie 2015-09-23 00:07:10 UTC
Okay we somehow seem to have lost GLX_MESA_copy_sub_buffer in the server GLX extension string.

I'm assigning this to ajax, though I'll keep looking at it

Comment 2 Fedora Update System 2015-09-23 01:57:01 UTC
xorg-x11-server-1.18.0-0.3.20150907.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16471

Comment 3 Ray Strode [halfline] 2015-09-23 18:10:07 UTC
see also bug 1249731 where i did the same "fix" for rhel 7.

Comment 4 Andre Robatino 2015-09-23 20:28:56 UTC
In my VirtualBox Rawhide guest, I immediately get the "Oh no!" screen instead of the GDM login screen after today's Rawhide updates (including xorg).

Comment 5 Andre Robatino 2015-09-24 01:54:21 UTC
(In reply to Andre Robatino from comment #4)
> In my VirtualBox Rawhide guest, I immediately get the "Oh no!" screen
> instead of the GDM login screen after today's Rawhide updates (including
> xorg).

However, the same update on F23 does fix the problem when running GNOME. (BTW, I had been able to use MATE without the issue before the update, as a workaround.)

Comment 6 Fedora Update System 2015-09-24 05:07:06 UTC
xorg-x11-server-1.18.0-0.3.20150907.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Andre Robatino 2015-09-26 03:10:28 UTC
(In reply to Andre Robatino from comment #4)
> In my VirtualBox Rawhide guest, I immediately get the "Oh no!" screen
> instead of the GDM login screen after today's Rawhide updates (including
> xorg).

Ignore - this was a result of https://bugzilla.redhat.com/show_bug.cgi?id=1265913 (an selinux bug).


Note You need to log in before you can comment on or make changes to this bug.