Bug 1265479 - AFR: cluster options like data-self-heal, metadata-self-heal and entry-self-heal should not be allowed to set, if volume is not distribute-replicate volume
AFR: cluster options like data-self-heal, metadata-self-heal and entry-self-h...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Sakshi
: Triaged, ZStream
Depends On: 1234995
Blocks: 1223636 1308414
  Show dependency treegraph
 
Reported: 2015-09-23 00:19 EDT by Sakshi
Modified: 2016-06-16 09:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1234995
: 1308414 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:37:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sakshi 2015-09-23 00:19:37 EDT
+++ This bug was initially created as a clone of Bug #1234995 +++

Description of problem:

When you have distribute or disperse volume, and you set data-self-heal, metadata-self-heal and entry-self-heal options on/off  it succeeds. 

Since when you try to set self-heal-daemon off/on on distribute, disperse volume , it give error self-heal-daemon can be set on distribute-replicate volume. Same error should be displayed when user tries to set data-self-heal, metadata-self-heal and entry-self-heal options on/off.


Version-Release number of selected component (if applicable):

[root@darkknightrises ~]# rpm -qa | grep glusterfs
glusterfs-client-xlators-3.7.1-4.el6rhs.x86_64
glusterfs-cli-3.7.1-4.el6rhs.x86_64
samba-vfs-glusterfs-4.1.17-7.el6rhs.x86_64
glusterfs-libs-3.7.1-4.el6rhs.x86_64
glusterfs-3.7.1-4.el6rhs.x86_64
glusterfs-api-3.7.1-4.el6rhs.x86_64
glusterfs-server-3.7.1-4.el6rhs.x86_64
glusterfs-debuginfo-3.7.1-4.el6rhs.x86_64
glusterfs-fuse-3.7.1-4.el6rhs.x86_64
glusterfs-geo-replication-3.7.1-4.el6rhs.x86_64


How reproducible:

100%

Steps to Reproduce:
1. Create distribute volume
2. set data-self-heal, metadata-self-heal and entry-self-heal option on/off. e.g gluster v set <vol-name> data-self-heal off
3. 

Actual results:

Commands succeeds 

Expected results:

Check should there, if there is distribute-replicate volume , then only data-self-heal, metadata-self-heal and entry-self-heal option should be allowed to set
Comment 1 Sakshi 2015-11-02 01:07:02 EST
Patch upstream http://review.gluster.org/12215
Comment 2 Niels de Vos 2016-06-16 09:37:36 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.