This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1265525 - [New] - upgrading console from 3.0 to 3.1 does not work
[New] - upgrading console from 3.0 to 3.1 does not work
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
3.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 3.1.2
Assigned To: Sahina Bose
RHS-C QE
: ZStream
Depends On:
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-09-23 03:06 EDT by RamaKasturi
Modified: 2016-03-01 01:11 EST (History)
8 users (show)

See Also:
Fixed In Version: rhsc-3.1.2-0.67
Doc Type: Bug Fix
Doc Text:
Previously, upgrade of rhsc-setup-plugin required a specific version of rhsc and rhsc packages could not be updated due to the version lock issue. As a consequence, upgrade from 3.0.x to 3.1.2 failed. With this fix, this package dependency issue is resolved and upgrade works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:11:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2015-09-23 03:06:40 EDT
Description of problem:
when customer has console installations of 3.0,3.0.1,3.0.2,3.0.3 and if trying to  upgrade it to 3.1 does not work.

Version-Release number of selected component (if applicable):
rhsc-3.0

How reproducible:
Always

Steps to Reproduce:
1. Have installations of 3.0 / 3.0.1 / 3.0.2 /3.0.3 
2. Now register to the channels which has latest packages for 3.1
3. Run yum update rhsc-setup/ rhsc-setup

Actual results:
rhsc-setup fails with error ***L:ERROR Internal error: cannot import name constants_access_plugin 

Expected results:
customer should be able to setup rhsc successfully.

Additional info:
Comment 2 RamaKasturi 2015-09-23 03:12:27 EDT
As a workaround copying /usr/share/ovirtengine/setup/ovirt_engine_setup/rhsc_constants_access_plugin.py as /usr/share/ovirt-engine/setup/ovirt_engine_setup/constants_access_plugin.py sloves the issue.
Comment 5 Sahina Bose 2015-10-21 02:02:25 EDT
Changed the import location of constants file to rhsc_constants_access_plugin which is provided by the rhsc-setup-plugins rpm
Comment 6 Sahina Bose 2015-10-21 06:35:21 EDT
Please test upgrading from 3.0.x to 3.1.2 as well (x should be less than 3)
Comment 7 Triveni Rao 2015-10-27 05:22:28 EDT
I have completed the upgrade tests and found that after upgrade, i cannot do rhsc-setup and i see some error like this:

[root@dhcp35-212 yum.repos.d]# rhsc-setup
***L:ERROR Internal error: 'module' object has no attribute 'ENGINE_SYSCONFDIR'
[root@dhcp35-212 yum.repos.d]# 

Steps followed:
1. install RHSC 3.0/3.0.1/3.0.2/3.0.3/3.0.4 on different machines.
2. upgrade to 3.1.2
3. do rhsc-setup and will see the above error.

Reproducible on all the upgrades successfully.
Comment 8 Triveni Rao 2015-11-09 08:01:29 EST
i have completed the upgrade test from 3.0.x to 3.1.2 and found no issues.

Steps followed:
1. install RHSC 3.0/3.0.1/3.0.2/3.0.3/3.0.4 based on RHEL6.6 on different machines.
2. check UI and versions.
3. upgrade to 3.1.2 (rhsc-3.1.2-0.67)
4. check the UI and versions of RHSC.

Upgrades went smooth and no issues found.

This bug is verified
Comment 9 Ramesh N 2015-12-13 23:54:01 EST
Doc text is not required as the bug is introduced in the intermediate build and customer won't face this issue at all.
Comment 10 Ramesh N 2015-12-14 00:20:27 EST
(In reply to Ramesh N from comment #9)
> Doc text is not required as the bug is introduced in the intermediate build
> and customer won't face this issue at all.

Sorry. I was wrong. I got confused with other bug bz#1290018
Comment 11 Divya 2016-01-29 05:01:09 EST
Sahina,

Could you please review and sign-off the edited doc text.
Comment 12 Sahina Bose 2016-01-29 05:51:18 EST
Looks good to me
Comment 14 errata-xmlrpc 2016-03-01 01:11:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0310.html

Note You need to log in before you can comment on or make changes to this bug.