Bug 1265589 - Logging out of gnome makes computer unusable
Logging out of gnome makes computer unusable
Status: CLOSED DUPLICATE of bug 1264904
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 05:57 EDT by Štefan Gurský
Modified: 2015-09-24 11:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 11:58:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Štefan Gurský 2015-09-23 05:57:29 EDT
Description of problem:
When logging out of gnome, I get black screen with “^@^@” in the top left corner. The computer shows no visible reaction to input.

Very similar thing happens when I press Ctrl+Alt+F1 – my Gnome Session is on f2, f3 and up show terminals, f1 shows black screen (without any text in this case) and cannot be exited.

Version-Release number of selected component (if applicable):
Name        : gdm
Epoch       : 1
Version     : 3.17.92
Release     : 1.fc23
Architecture: x86_64



Steps to Reproduce:
1. Log out from gnome session (click on top right corner menu, click on name, click on logout)
2. observe black screen


Actual results:
Black screen (with ^@^@ in top left corner)

Expected results:
login screen

Additional info:

(I have no idea what of the following could be relevant)

It seems that I get to similar state also if I press esc during boot to turn off splash screen.


$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M]

In F22 I had X login screen since wayland crashed. I could use wayland only if I blacklisted radeon driver (radeon.modeset=0 rd.driver.blacklist=radeon on cmdline and blacklist radeon in /etc/modprobe.d/blacklist-radeon.conf). However, it seems to have no effect here.

I get this in journal often:

sep 22 23:47:37 zork kernel: radeon 0000:03:00.0: WB enabled
sep 22 23:47:37 zork kernel: radeon 0000:03:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xffff880240609c00
sep 22 23:47:37 zork kernel: radeon 0000:03:00.0: fence driver on ring 1 use gpu addr 0x0000000040000c04 and cpu addr 0xffff880240609c04
sep 22 23:47:37 zork kernel: radeon 0000:03:00.0: fence driver on ring 2 use gpu addr 0x0000000040000c08 and cpu addr 0xffff880240609c08
sep 22 23:47:37 zork kernel: radeon 0000:03:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0xffff880240609c0c
sep 22 23:47:37 zork kernel: radeon 0000:03:00.0: fence driver on ring 4 use gpu addr 0x0000000040000c10 and cpu addr 0xffff880240609c10
sep 22 23:47:37 zork kernel: radeon 0000:03:00.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc90001835a18
sep 22 23:47:37 zork kernel: radeon 0000:03:00.0: VCE init error (-110).
sep 22 23:47:37 zork kernel: [drm] ring test on 0 succeeded in 1 usecs
sep 22 23:47:37 zork kernel: [drm] ring test on 1 succeeded in 1 usecs
sep 22 23:47:37 zork kernel: [drm] ring test on 2 succeeded in 1 usecs
sep 22 23:47:37 zork kernel: [drm] ring test on 3 succeeded in 5 usecs
sep 22 23:47:37 zork kernel: [drm] ring test on 4 succeeded in 5 usecs
sep 22 23:47:38 zork kernel: [drm] ring test on 5 succeeded in 1 usecs
sep 22 23:47:38 zork kernel: [drm] UVD initialized successfully.
sep 22 23:47:38 zork kernel: [drm] ib test on ring 0 succeeded in 0 usecs
sep 22 23:47:38 zork kernel: [drm] ib test on ring 1 succeeded in 0 usecs
sep 22 23:47:38 zork kernel: [drm] ib test on ring 2 succeeded in 0 usecs
sep 22 23:47:38 zork kernel: [drm] ib test on ring 3 succeeded in 0 usecs
sep 22 23:47:38 zork kernel: [drm] ib test on ring 4 succeeded in 0 usecs
sep 22 23:47:38 zork kernel: [drm] ib test on ring 5 succeeded

In F22 I got it on any Ctrl+Alt+F_ change.
Comment 1 Štefan Gurský 2015-09-24 11:58:36 EDT
I think this can be a duplicate. I will reopen if necessary.

*** This bug has been marked as a duplicate of bug 1264904 ***

Note You need to log in before you can comment on or make changes to this bug.