Bug 126559 - OpenOffice.org 1.1.1 cannot see CUPS printer classes
OpenOffice.org 1.1.1 cannot see CUPS printer classes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 04:54 EDT by David W. Legg
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 12:21:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David W. Legg 2004-06-23 04:54:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040113

Description of problem:
Added a printer in CUPS using all the default printer settings for the
type of print.

Then created 3 printer classes with different print resolutions.

However, OOo can only see the original print queue, not the 3 classes.

Since the spadmin tool has been deleted, there is no obvious way of
printing to my 3 extra printer classes at different resolutions. This
seems to be the new and correct way of doing printing in FC2, so I
have no problem with the deletion of spadmin, but surely OOO should
spot the 3 additional printer classes created by CUPS?

Version-Release number of selected component (if applicable):
OpenOffice.org 1.1.1-4

How reproducible:
Always

Steps to Reproduce:
1. Add printer using KDE Control Centre.
2. Add 3 (sub-)classes at different resolutions.
3. Start OOo and enter print dialogue.

    

Actual Results:  Can only see one print queue instead of four.

Expected Results:  Expected to see all four queues.

Additional info:
Comment 1 David W. Legg 2004-06-23 04:56:04 EDT
Note: this is not the same as Bug #124655.
Comment 2 Sepehr 2004-07-10 07:52:00 EDT
I'd like to also be ability to print through kprinter as well for pdf
generation as well. The built in pdf generator does not do brochure an
other print options. Not to mention I need the options that are not
there if you don't print through kprinter (like duplex, multi-page
reduction, draft quality etc). 
Comment 3 Chris Halls 2004-08-25 06:07:43 EDT
This is fixed as of this patch in ooo-build:

2004-07-08  Chris Halls  <halls@debian.org>

        * patches/OOO_1_1/psprint-cups.diff: Backport
        pl's multiple CUPS instances fixes from IZ#30914/7.
        Debian bug #250981.

I don't know which Fedora packaage version this will correspond to.
Comment 4 Dan Williams 2004-11-08 12:21:56 EST
David, please test with the OOo 1.1.2-10.fc2 version in FC2 updates
and reopen this bug if the problem persists.  That version should have
the fix that Chris Halls mentions above.
Comment 5 David W. Legg 2004-11-08 15:18:33 EST
Spiffing. Now works with all the latest FC2 stuff. Cheers.

Note You need to log in before you can comment on or make changes to this bug.