Bug 1265652 - Impossible to work with Business Central in IE10
Impossible to work with Business Central in IE10
Status: CLOSED DEFERRED
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
All Windows
urgent Severity urgent
: ---
: ---
Assigned To: manstis
Lukáš Petrovický
: TestBlocker
: 1265663 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 08:21 EDT by Kirill Gaevskii
Modified: 2015-10-15 04:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 04:17:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
6.2.ER3 in IE10 (8.61 MB, application/octet-stream)
2015-09-23 08:21 EDT, Kirill Gaevskii
no flags Details
BusinessCentral IE10 (3.96 MB, image/gif)
2015-09-24 08:01 EDT, Jeremy Lindop
no flags Details

  None (edit)
Description Kirill Gaevskii 2015-09-23 08:21:07 EDT
Created attachment 1076175 [details]
6.2.ER3 in IE10

Description of problem:
It is impossible to change existing OrgUnits, Repositories, Projects, Project properties and so on. Not possible to open existing Business Processes, can't to work with new Business Process in a proper way.

Version-Release number of selected component (if applicable):
6.2.ER3

How reproducible:
always

Steps to Reproduce:
1. Open Authoring Perspective try to change OrgUnit, Repository, Projects.
2. Reset perspective or go to Home -> Authoring Perspective
3. Try to open existing Business Process
4. Reset perspective or go to Home -> Authoring Perspective
5. Create new Business Process. Add End Event, try to save project
6. Reset perspective or go to Home -> Authoring Perspective
7. Create new Business Process. Add new Task, try to add Input/Output variable
8. Reset perspective or go to Home -> Authoring Perspective

Actual results:
Not possible to work with Designer.

Expected results:


Additional info:
Comment 1 Kirill Gaevskii 2015-09-23 08:45:09 EDT
*** Bug 1265663 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Lindop 2015-09-24 08:01 EDT
Created attachment 1076486 [details]
BusinessCentral IE10
Comment 3 Jeremy Lindop 2015-09-24 08:05:03 EDT
This appears to be a general problem with Business Central, not specific to jBPM Designer. See attached video in Comment 2, which was created using kie-wb-6.3.0.Final-eap6_4.war downloaded from http://kie-releases.lab.eng.brq.redhat.com/kie-artifacts/6.3.0.Final/, dated 23-Sep-2015 17:24, running under EAP 6.4.
Comment 5 Marco Rietveld 2015-09-24 08:40:52 EDT
Mike, if someone else is better suited to attack this problem, please feel free to reassign it. And from the rest of us, our enormous thanks for tackling this!
Comment 6 Jeremy Lindop 2015-09-24 10:13:53 EDT
I forgot to note that this version of Business central seems to work fine in IE9 and IE11. It's just IE10 where there's a problem.
Comment 7 manstis 2015-09-25 07:23:28 EDT
This is clearly two issues; 1) WorkbenchPanels (in uberfire) are not being resized in IE10 leading to them to show no content, and 2) Designer seems to have some issues (the Data Mapper tries to close the editor by the look of the video). I'll do some investigation and probably split this BZ into two.
Comment 8 manstis 2015-09-28 11:26:09 EDT
Looks like Uberfire (tried 0.7.x and 0.8.x) doesn't like IE10 (or more likely our use of GWT2.8 on IE10 could be causing some problems). Running uberfire-showcase (compiled -Dfull, deployed on Linux running IE10 in VirtualBox) the following error occurs when navigating to other perspectives:

SCRIPT438: Object doesn't support property or method 'forEach' 
c3.min.js, line 2 character 8531
SCRIPT438: Object doesn't support property or method 'forEach' 
c3.min.js, line 2 character 8531
MutationObserver not defined.
Comment 9 manstis 2015-09-28 14:50:45 EDT
OK, 'forEach' was added to JavaScript 1.7 and requires IE(10) to be ran in (at least) 'IE9 Standards Mode'. See https://msdn.microsoft.com/en-us/library/ff679980(v=vs.94).aspx
Comment 11 manstis 2015-09-29 09:30:25 EDT
Changes in PR were tested; but did not resolve issue... still investigating.

Note You need to log in before you can comment on or make changes to this bug.