Bug 1265670 - shogun: FTBFS in rawhide
shogun: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shogun (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Björn 'besser82' Esser
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks: python-PyMVPA
  Show dependency treegraph
 
Reported: 2015-09-23 09:02 EDT by Jitka Plesnikova
Modified: 2015-12-09 02:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 02:55:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitka Plesnikova 2015-09-23 09:02:26 EDT
Description of problem:
Package shogun fails to build from source in rawhide.

Version-Release number of selected component (if applicable):
4.0.1-0.1.git20150808.779c3ad.fc24

Steps to Reproduce:
koji build --scratch f24 shogun-4.0.1-0.1.git20150808.779c3ad.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/shogun

The details about the first build which failed:
https://apps.fedoraproject.org/koschei/package/shogun/824910

One of 2 errors:
751/1256 Test #212: integration-python_modular-tester-features_dense_protocols_modular ..................................................................***Failed   13.30 sec
numpy version >= 1.5 is needed
features_dense_protocols_modular.py setting 1/1              ERROR
The following tests failed!
	features_dense_protocols_modular.py setting 1/1

It seems the problem was with version check, because numpy-1.10.0-0.b1.fc24.x86_64 was installed during the build.
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-29 10:57:27 EST
Now it fails for a different reason, but it's still an issue.
Comment 2 Björn 'besser82' Esser 2015-11-29 12:15:14 EST
The newer problem might be caused by changes in Python 3.5 libs.  However, the problem is known [1] and we'll find a solution.


[1]  https://github.com/shogun-toolbox/shogun/issues/2930
Comment 3 Upstream Release Monitoring 2015-12-08 16:46:51 EST
besser82's shogun-4.0.1-0.4.git20150913.d8eb73d.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=704166
Comment 4 Björn 'besser82' Esser 2015-12-09 02:55:00 EST
Rebuilding with patched SWIG worked.

Note You need to log in before you can comment on or make changes to this bug.