Bug 1265794 - [RFE] NFS interface to RGW/S3
Summary: [RFE] NFS interface to RGW/S3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 1.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Matt Benjamin (redhat)
QA Contact: shylesh
Bara Ancincova
URL:
Whiteboard:
: 1265793 (view as bug list)
Depends On:
Blocks: 1322504
TreeView+ depends on / blocked
 
Reported: 2015-09-23 18:53 UTC by Neil Levine
Modified: 2017-07-30 15:47 UTC (History)
13 users (show)

Fixed In Version: RHEL: nfs-ganesha-rgw-2.3.2-1.el7cp Ubuntu: nfs-ganesha-fsal_2.3.2-2redhat1xenial
Doc Type: Technology Preview
Doc Text:
.The NFS interface for the Ceph Object Gateway The Ceph Object Gateway now includes a new NFS interface that presents buckets and objects as directories and files. The main purpose of this new functionality is to facilitate migration from POSIX applications and workloads to the Ceph Object Gateway.
Clone Of:
Environment:
Last Closed: 2016-08-23 19:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1359060 0 unspecified CLOSED 2.0: Doc RFE: Need documentation for nfs rgw 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Internal Links: 1359060

Description Neil Levine 2015-09-23 18:53:35 UTC
Provide an NFS interface to RGW which presents buckets/objects as directories/files using a Ganesha FSAL.

Comment 4 Neil Levine 2015-09-23 18:56:55 UTC
*** Bug 1265793 has been marked as a duplicate of this bug. ***

Comment 14 Matt Benjamin (redhat) 2016-06-15 21:59:51 UTC
We need packaging for nfs-ganesha (we believe, from RHGS).  Some details of where packages are to be installed may be required.  Needs to be co-installed with librgw2.

Comment 15 Ken Dreyer (Red Hat) 2016-06-15 22:00:57 UTC
Exactly what packages (Name-Version-Release) do we need to ship for this?

Comment 27 shylesh 2016-08-05 17:05:03 UTC
Since all the targeted tests for nfs-rgw techpreview is done , marking this as verified. Please note that platform tested for techpreview is RHEL7.2.

Comment 29 errata-xmlrpc 2016-08-23 19:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755


Note You need to log in before you can comment on or make changes to this bug.