Bug 1265799 - hidpi/wayland: mouse cursor too big in gnome-shell and xwayland clients
hidpi/wayland: mouse cursor too big in gnome-shell and xwayland clients
Status: CLOSED DUPLICATE of bug 1268495
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 15:20 EDT by Fabio Valentini
Modified: 2015-10-12 09:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 09:50:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot documenting 4x size cursor (4.37 MB, image/png)
2015-09-23 15:20 EDT, Fabio Valentini
no flags Details

  None (edit)
Description Fabio Valentini 2015-09-23 15:20:36 EDT
Created attachment 1076289 [details]
screenshot documenting 4x size cursor

Description of problem:
start gnome wayland session (but also occurs at gdm login screen)

Hardware:
intel graphics (i7-4500U CPU, HD 4?00, Haswell)


Version-Release number of selected component (if applicable):
mutter-3.17.92-1.fc23.x86_64
gnome-shell-3.17.92-1.fc23.x86_64


Actual results:
cursor is not only scaled up to 2x pixel-size, but 4x pixel-size for gnome-shell and xwayland clients (e.g. google chrome). hovering over wayland clients (regular gnome applications, e.g. nautilus, gnome-terminal, etc.), the cursor returns to correct size (scaled to 2x).

the attached screenshot shows huge cursor in gnome-shell, not pointing at any particular window.
Comment 1 Robert Ma 2015-10-09 15:50:23 EDT
I have the same issue under GNOME 3.18 (Wayland):

mutter 3.18.0
gnome-shell 3.18.0
gtk3 3.18.1

To sum up, assuming the default cursor size under normal DPI is 1x. Then on a HiDPI display, cursor size is 2x in nautilus, which is desired; however, in Firefox or GNOME Shell (also in the GNOME login screen, which uses Wayland by default now), cursor size is 4x. It seems there are some duplicate logic in terms of handling HiDPI cursor scaling, which causes the cursor size to be doubled twice.

By the way, when the cursor size is 4x, the cursor moving speed is also much slower.
Comment 2 Michael Catanzaro 2015-10-12 09:50:12 EDT

*** This bug has been marked as a duplicate of bug 1268495 ***

Note You need to log in before you can comment on or make changes to this bug.